Date is considered invalid!

  • Profile Image
    Valerie 
    Asked on October 06, 2015 at 08:27 AM

    On the form:

    http://www.jotform.com//?formID=52712741456960

    When I fill the year of the date fields, the whole date is suddenly considered invalid. Yet it seemed to be working fine until today? Any idea? Thanks in advance!

  • Profile Image
    victor
    Answered on October 06, 2015 at 10:47 AM

    Hi,

    While reviewing your form I noticed that this fields is required, but you also have a condition. This condition makes the field required if it is empty. 

    It seems that there is a conflict between this two. Since This field is already required, you do not require this condition. Once you remove this condition, you should not have any more issues.

    Please let us know if you require further assistance.

    Regards

  • Profile Image
    Valerie 
    Answered on October 06, 2015 at 11:47 AM
    Actually, I added this condition because the regular requirement
    wouldn't work, maybe because of the page break, I am not sure. But
    anyway, I already tried making this field not required at all, and the
    problem remained, so it is not related to a conflict. I will remove both
    requirement so you can test it on your end. Do you have any further
    suggestion?
    Le 06/10/2015 17:44, JotForm Support Forum a écrit :
    ...
  • Profile Image
    victor
    Answered on October 06, 2015 at 12:37 PM

    Hi,

    I was able to reproduce this issue. It seems that the issue occurs when you prepopulate the date field. Once this field is changed the validation get activated.

    I noticed if I enter an invalid date and refresh the form. All the fields are populated and the date is valid (even if it should not be). 

    I have forwarded this to our back end team. They are currently working on the issue and will get back to you as soon as possible. In the mean time, the only suggestion I could make is to use the DATE FIELD instead of the BIRTH DATE FIELD.

  • Profile Image
    NicholasWestley
    Answered on October 06, 2015 at 11:23 PM

    Hi,

    This was a temporary glitch that has now been resolved.  Sorry for the inconvenience.

    Rgards,

    Nicholas