Previously viewed Folder keeps opening or being remembered even after navigating to "My Forms" section

  • Profile Image
    markashton
    Asked on October 09, 2015 at 06:29 AM

    Hi,

    The My Forms view keeps reverting to an old folder that I haven't accessed for sometime.

    So, if select a folder and work on a form ... and then logout when finishing ... if I login again ... it goes back to the old folder.

    I don't know whether it is a cache issue or something but it isn't playing the way it should.

    Anyone else noticed this?

    Is there a workaround? 

    Many Thanks

    Regards Mark

  • Profile Image
    Charlie
    Answered on October 09, 2015 at 12:22 PM

    Hi Mark,

    I was getting that same problem. But mine happens when I do these steps:

    1. Log in to JotForm account.

    2. Click any of the Folders. In my case, I clicked "Test Forms"

    3. Now these are the problems I'm seeing after opening a folder:

    Problem 1: When navigating back to "My Forms" (the one besides the "Templates" menu), it will open the previously viewed folder

    Problem 2: When you navigate back to "My Forms" (the one besides the "Templates" menu) and log out to your account, when you log back in it will open the previously viewed folder.

    Problem 3: When you navigate back to "My Forms" (the one above the folders) and create a form there, that form will be added in the previously viewed folder

     

    The problem is that the "My Forms" section doesn't seem to stay on that part when you have previously opened a folder. To fix this, you can try the steps below.

    1. First, click the "My Forms" section just above the folders (not the one at the top page besides "Templates")

    2. After that, log out to your account then log back in.

    3. It should then open the "My Forms" section by default and not the previously opened folder.

     

    Clearing the cache might also help.

    I will forward this to our developers so that they can further investigate and have it fixed. Apologies for the inconvenience.

  • Profile Image
    markashton
    Answered on October 10, 2015 at 08:34 AM

    Hi Charlie,

    Thnajks for recognising the problem. I have tried what you suggested ... but strangely I have a very persistent folder that it always goes back to.

    I've tried logging out on a number of occasions to clear the issue but to no avail.

    I can live with it ... but it affects productivity.

    Devs should nail this.

    Let me know if resolved.

    Thanks Mark

  • Profile Image
    Jan
    Answered on October 11, 2015 at 03:00 AM

    Thank you for the update. Our developers are still investigating the issue. We'll let you know via this thread once an update is available.

  • Profile Image
    markashton
    Answered on October 15, 2015 at 09:13 AM

    Sort this out please. It's a nightmare.

    What are devs doing that is more important than getting the interface working as it should?

    The 'My Forms' page doesn't work properly .... fix it!

    That's free feedback in my working day to improve your product. Take it on board FFS

    Mark

  • Profile Image
    Mike_G
    Answered on October 15, 2015 at 10:27 AM

    Truly, we appreciate your time and effort in bringing this to our attention. Since this has been forwarded to our developers, please be assured that it is being worked on and will be fixed as soon as possible. I'm sorry if we cannot provide any ETA to when this will be okay but, as always, you will be notified via this thread for any updates, if there are any. Thank you for your patience. 

  • Profile Image
    markashton
    Answered on October 27, 2015 at 10:42 AM

    Respectfully,

    If you appreciated my effort you'd have sorted this out by now.

    I'm shouting at the screen here.

    It never goes back to the folder I want ... 

    It's crap ... take it from me .... and what with the form designer on the blink ... jeez

    PS Don't use ETA in the reply and please don't apologise ... 

    Mark

  • Profile Image
    Charlie
    Answered on October 27, 2015 at 11:56 AM

    I understand. Currently, the developer assigned on this is still working on the problem. Let me notify him again and see if we can get any news about the fix.

  • Profile Image
    markashton
    Answered on October 27, 2015 at 11:57 AM

    Thnaks .. soz about the rant ... no reply required.

    Thnaks 

  • Profile Image
    markashton
    Answered on November 03, 2015 at 05:18 AM

    Does anyone actually use Jotform?

    This is the most annoying of problems. Everytime you click My Forms there is no "memory" of where you last were.

    Tell me ... has anyone actually experienced this problem at Jotform?

    I'd be interested to know.

    Regards Mark

    PS The developer isn't working on the problem - that's not factually accurate is it?

  • Profile Image
    Charlie
    Answered on November 03, 2015 at 08:36 AM

    I'm sorry Mark, I understand that that bug is indeed annoying, especially if you are moving to different folders. I'm also getting that problem as I mentioned in our earlier conversation, although I don't really move a lot from different folders.

    The ticket is still unresolved and I have already sent a notification to the developer last time, I'll leave another notification to see if we can get any update.

     

    PS The developer isn't working on the problem - that's not factually accurate is it?

    Unfortunately, I'm unable to see or monitor what they are currently working, but it's already assigned to them with a high priority so I presume that someone in their team is currently looking at it.

  • Profile Image
    alp_deniz
    Answered on November 04, 2015 at 04:52 PM

    Hello Mark,

    My Forms page's 'remember last folder' feature is re-activated. Could you confirm if it works as expected?

    Kind regards

  • Profile Image
    markashton
    Answered on November 05, 2015 at 05:17 AM

    Hi alp_deniz

    How's you?

    Ok so give me a day or two to establish the workflow of what's happening and I'll be back in touch.

    No reply required

    Regards Mark

  • Profile Image
    betadac
    Answered on November 14, 2015 at 01:27 AM

    I am expericing this same problem. Any fix yet?
  • Profile Image
    Mike_G
    Answered on November 14, 2015 at 06:55 AM

    @betadac

    I have moved your concern to a new thread. We believe that we can better assist our users if they have a thread of their own for every question that they have to avoid confusion with the answers. 

    You can click on this link to go to that thread. 

    Thank you.

  • Profile Image
    markashton
    Answered on November 14, 2015 at 08:06 AM

    This is mean't respectfully ... I use language to convey an idea ....

    No Mike ... that's a crap idea ... how can any person from the consumer side of things follow anything. I started the thread ... I want to follow other people's experiences on my thread ... so I can track it. I didn't start the thread for you to hijack it and send people off down some "bolt hole" of their own.

    That's the whole point of a forum. For your users. I've said this before, you are product-driven at Jotform not customer-driven. This forum is more for you than us!

    betadac is echoing exactly what I have put. What happens now ... a solution is posted on his/her thread and I don't know about it? Don't tell me that hasn't happened. It has ... a lot! Just ask me and I'll explain.

    @alp_deniz ...

    In a nutshell  ... the problem still exists ... there is no fluidity or workflow as the "last folder" concept is broken. It doesn't keep up with the last folder thing ... it just remembers some old folder that you used 4 days ago ...

    PS Why don't we start a new thread ... then we can have about 3 of them moving forward simultaneously all on the same topic .... sigh ....

    Regards Mark

  • Profile Image
    Welvin
    Answered on November 14, 2015 at 04:46 PM

    Hi Mark,

    Our apologies. Would you mind trying to clear your browser cookies for Jotform? This method is not mentioned by my colleagues and I think this will work (hopefully). After that, try to login again and start clicking folders and going back at it by refreshing the page (instead of logging out and logging in again). 

    If the above steps will work, try to check it again by logging out and logging in again. 

    Thank you.

  • Profile Image
    alp_deniz
    Answered on February 20, 2016 at 11:17 PM

    Hello Mark,

    It should be working as expected now.

    My sincere apologies for the delayed fix. 

    Kind regards,

    Alp