Text Field Masked Input validation causes error "Field Value must fill mask" if additional characters are tried to be added after the end

  • Profile Image
    AdamCKL
    Asked on October 13, 2015 at 10:16 PM

    I have created the following fill mask in the form and it works on my Desktop but not on mobile device.

    It pops out Error: Field Value must fill mask on my phone.



    Please see my example

  • Profile Image
    Sammy
    Answered on October 14, 2015 at 07:03 AM

    I did a test on a clone copy of your form on my mobile device and was able to replicate the issue on it as well as the desktop.

    The issue appears to be caused by the brackets at the end (). For now you can exclude it in you mask, then test your form again.

    I will forward this issue to our development team for additional investigation.

  • Profile Image
    Sammy
    Answered on October 15, 2015 at 03:14 AM

    Apologies for not including screenshots from the recreation of your issue on my end.

    Below are the screenshots showing the error I managed to recreate on my end.

    I have already forwarded this to our developers.

  • Profile Image
    AdamCKL
    Answered on October 15, 2015 at 04:48 AM

    Thank you :) Please let me know when this one is fixed.

  • Profile Image
    Sammy
    Answered on October 15, 2015 at 05:49 AM

    You will receive updates regarding the fix from our developers via this thread

  • Profile Image
    AdamCKL
    Answered on October 30, 2015 at 04:57 AM

    May I know any updates from you?

  • Profile Image
    Ben
    Answered on October 30, 2015 at 07:04 AM

    Unfortunately there are no updates in regards to this, but I have found during my tests that this happens only if you type the last character and then as the carrot is moved behind the closing bracket, if you try to add any new characters, it will show this error even if it did not allow the same to be added.

    I will add this info to the ticket so that our developers have a bit more details on the issue.

    As soon as we have any update on this we will update you about it through this thread.

  • Profile Image
    cheung2701
    Answered on February 29, 2016 at 08:38 PM

    Hi Ben,

    May I know if this has been fixed?

  • Profile Image
    Chriistian
    Answered on March 01, 2016 at 02:50 AM

    I tested the form and I can see that the error "Field value must fill mask" still appears when the field is filled. Unfortunately there are currently no updates regarding your issue. I have contacted our back-end team to see if they have any news on their end. We will inform you on this thread as soon as there are any updates.