What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form top logo is partially hidden after applying a Theme with logo

    Asked by dakotahorizons on October 23, 2015 at 12:16 PM

    We have a theme applied to our forms. When we go in and apply it to a form, it shows up correctly. When we go to the live form, it cuts the top of the theme off. This used to work and it looked fine, but just recently something happened and it doesn't display correctly anymore.

    What can I change to make this work?

     

    Thanks,

    Jay

    Page URL:
    https://form.jotform.com/52884274058161

    form cover form logo
  • Profile Image

    Answered by Carina on October 23, 2015 at 02:23 PM
     
     
    body, html {
           margin: 40px 0 0 !important;
       }
     

    Let us know if we can assist you further.  

  • Profile Image

    Answered by dakotahorizons on October 27, 2015 at 09:25 AM

    Now when I put that CSS code in, it makes a new theme without any formatting. Also, the theme we originally created will not apply and the forms will only take the theme that is created when I saved the theme with the new CSS code.

     

    The theme was designed and then shared from our jenebo account.

     

    Jay

  • Profile Image

    Answered by Carina on October 27, 2015 at 10:56 AM

    Please try using the Revision History to restore the form to a previous version:

    http://www.jotform.com/blog/95-Introducing-Form-Revisions-Never-Lose-Your-Work-Again- 

    If the logo is still partially hidden please try adding this css code:

    .jotform-form {
        padding: 120px !important;
    }
     
    You can adjust the value of the green part.
    Let us know if the problem persists.
  • Profile Image

    Answered by jenebo on October 27, 2015 at 12:02 PM

    This method seems to be band-aiding the original issue. The theme worked before, and all of sudden in the last couple weeks, it went awry. When applied to any of my forms, the same result happens. Wouldn't this be some sort of setting on the theme itself rather than adding code to each of my already-built forms?

  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on October 27, 2015 at 02:57 PM

    Instead of adding the extra code, I've set the Bottom Margin to 0 px

     

    Now the image at the top is being seen completely.

  • Profile Image

    Answered by dakotahorizons on October 27, 2015 at 03:35 PM

    I did change the bottom margin to 0px on the theme and re-saved it (I share this theme so our sub-accounts can see it). Using the same theme, this one works, while this one does not. I cannot tell what the difference is between the theme applied to these two forms. Most of my forms look like the latter, although a couple do look like the first link.

    Can you spot anything I am doing wrong?

    Jay

  • Profile Image
    JotForm Support

    Answered by Mike on October 27, 2015 at 06:05 PM

    It appears that there is currently an issue with the form covers when they are applied as a part of a theme. You may try adding Carina's CSS directly to the Theme (then you might need to re-apply updated theme to your forms).

    .jotform-form {
    padding: 120px !important;
    }

    We have attached a bug report ticket to this thread and forwarded it to our Development Team for consideration.

  • Profile Image
    JotForm Support

    Answered by Mike on October 27, 2015 at 06:13 PM

    I cannot tell what the difference is between the theme applied to these two forms. Most of my forms look like the latter, although a couple do look like the first link.

    Correct forms are probably re-saved in form designer.

    In other words, you can try to re-save a form in form designer to fix the logo positioning issue. Re-saving will add default CSS which will add required spacing.

    Thank you.