What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form not Redirecting to Thank You URL after submissions

    Asked by beatsahead on November 04, 2015 at 06:45 AM

    my form at beatsahead.com is supposed to recirect to another partially completed form, but is getting stuck at https://submit.jotformeu.com/submit/52762376904361/

    jotformeu stuck another Getting redirect thank you url URL
  • Profile Image
    JotForm Support

    Answered by KadeJM on November 04, 2015 at 11:36 AM

    I see you have the following form mentioned which is embedded at the top of your website but it is getting stuck at submit instead of redirecting to a partially populated secondary form, correct?

    I noticed you have that set to then redirect the user over here http://beatsahead.com/dj-booking-page/?all2={all1}&peak2={peak1}&eventDate[month]={musicStart:month}&eventDate[day]={musicStart:day}&eventDate[year]={musicStart:year} shortly afterwards.

    After trying this it's become obvious that your form isn't submitting properly. as I've realized that your form http://www.jotformeu.com/form/52762376904361 is on our EU Servers and I also found you are using the form's full source code.

    How long ago did you add the source code to your webpage? Recently? Or awhile ago?

    If it was awhile ago then I would suggest grabbing a fresh copy of the form's full source code then re-embed it because of the fact that it contains a few changes within it due to the newer EU Datacenter Laws that caused the Safe Harbor Invalidation. 

    After that try it again to test it and it should work.

     

    But if for some reason you continue to have any further problems or if you've already done that then please let us know so that we can check on this issue more if needed.

  • Profile Image
    JotForm Support

    Answered by KadeJM on November 04, 2015 at 12:08 PM

    I decided to take a longer and deeper look into the issue at hand as something didn't seem right about this problem.

    Come to find out I found that the problem even occurs on your form by itself so I believe it's actually safe to disregard the initial response as it appears that it is not the source code and I do apologize about providing you with the incorrect information. Please disregard that part above.

    I found that this issue is due to a problem with your Hidden Fields which I was able to narrow it down to. However, I am still testing this to figure out why that is the cause so I will need a bit more time to figure out why this is occurring if that would be okay with you. This way we can get the issue corrected immediately for you and anyone else that might be experiencing the same problem.

    I'll update you again as soon as possible once I know more.

  • Profile Image

    Answered by beatsahead on November 04, 2015 at 03:01 PM

    Thanks, I'd appreciate it

  • Profile Image
    JotForm Support

    Answered by KadeJM on November 04, 2015 at 04:01 PM

    Thank you for your patience.

    Originally I thought it might be a technical issue until I found that was not the case which is a good thing since it means this is fixable.

    I found the problem is occurring because of the Max Value and the Calculation you have set for your Spinner Field that you have titled as "Length of Party".

    This is happening because the Calculation for your Dates is sending a much larger value into that field than what is allowed since currently you have it set to a Max Value of only 10.

    You can see in the second screenshot below that I unhid your spinner field via a separate test form just to show you what is happening.

    If you are using that as your cost for the Spinner Field then I would suggest raising that Max Value and then it'll work as you need and should then allow you to submit it.

    It seems you have the Date of the Future Event is First followed by the Date that the Event had Happened. But, that's unclear as I stated above since your configured fields wouldn't allow past dates in either field and this only confused me more during the investigation.

    To my knowledge for Various Hosting and Events I know that you usually have a Date the Event Actually Happened (Past Date) as an example my Wife and I were married on 3/21/15 earlier this year which means we will have our Anniversary on 3/21/16 (Future Date) to schedule a secondary Date for a Future Event. 

    So unfortunately though I am not quite sure how exactly how you want to do this? Or if you are trying to reverse that possibly somehow?  

    If you need more help with this beyond that then please explain how you plan to make it work for those and we will gladly assist you further.

     

  • Profile Image

    Answered by beatsahead on November 04, 2015 at 04:09 PM

    I am a little confused, the length of party would never exceed 10 hours, as a party is usually from 7pm until midnight or 1am, because the end time is often the next day I need to have the dates and times this way to work out the correct length of the party.

    It would be very unusual for someone to request an event for longer than 10 hours, which is why that is the max value allowed in the length of party field.

  • Profile Image
    JotForm Support

    Answered by jonathan on November 04, 2015 at 09:14 PM

    Hi,

    I test submitted your jotform http://www.jotformeu.com/form/52762376904361 and it successfully redirected to the other form using the Thank You URL redirect.

    Please refer to the image below that shows my test.

    Is the form embedded on a website? Can you share to us the URL of the website where the 1st form was embedded. We can also test it on the actual embedded form.

    Let us know if issue still persist.

     

     

  • Profile Image

    Answered by beatsahead on November 05, 2015 at 03:47 AM
    Thanks, it appears to be working now
  • Profile Image

    Answered by beatsahead on November 09, 2015 at 01:32 PM

    This is sticking again now, I'd really appreciate knowing why, or what I can do about it?

  • Profile Image
    JotForm Support

    Answered by Kevin_G on November 09, 2015 at 04:05 PM

    Hello,

    Thank you for contacting us.

    I've checked your form and I can see that is working fine :

    Please, try again and if the issue is still there let us know , we will be glad to help you.

  • Profile Image

    Answered by beatsahead on November 09, 2015 at 05:50 PM

    Bizzarre, it's working again now, it was sticking at  https://submit.jotformeu.com/submit/52762376904361/ all afternnon

  • Profile Image
    JotForm Support

    Answered by BDAVID on November 09, 2015 at 07:33 PM

    That's odd, keep us updated if it happens again, so we can check live when the problem occurs.

  • Profile Image

    Answered by beatsahead on November 12, 2015 at 04:45 AM

    It seems that it's when children's party is selected that it gets stuck, could it be due to the ' ?

  • Profile Image
    JotForm Support

    Answered by BDAVID on November 12, 2015 at 08:10 AM

    You are correct, I just tried it selecting that option, and it got stuck:

    I have cloned your form to further test, I will get back to you when I find a solution for this, or I might need to forward it to our second level for further help.

  • Profile Image
    JotForm Support

    Answered by BDAVID on November 12, 2015 at 08:33 AM

    Hi, upon further testing, I see that the problem occurs between the apostrofe and condition 11(Where you have numeric and text values):

    If you remove the apostrofe('), it will work.

     

  • Profile Image

    Answered by beatsahead on November 12, 2015 at 08:35 AM

    Do you mean I should remove the apostrophe from the select options.?

  • Profile Image
    JotForm Support

    Answered by KadeJM on November 12, 2015 at 10:52 AM

    To be honest I'm unsure of what Apostrophe David is referencing to you above involving Condition 11 since per his screenshot there is none shown there and I do apologize about any confusion.

    I also do believe you have the right Apostrophe in the Dropdown Options for selection. The only realization that I can think of is that it's possible that he may have meant the issue might be caused by the fact that the Apostrophe gets pulled into the condition as apart of the text and value data which therefore appears to then cause it to hang.

    I would suggest removing the Apostrophe for that particular option then test it on your end again and let us know as it should then work normally afterwards. On my end I can confirm this does correct the problem but would like to have you double check it on your end again just to be sure.