What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    New MailChimp Integration Wizard not receiving submissions and can't edit integration

    Asked by Project1000 on November 04, 2015 at 11:45 AM

    I've disconnected and reconnected this integration, created a new api key, and nothing is working. I've selected to add existing entries to mailchimp and those did not work either.

    Page URL:
    http://www.aliciabright.com

    mailchimp integration
  • Profile Image
    JotForm Support

    Answered by Mike on November 04, 2015 at 04:06 PM

    Thank you for contacting us.

    I have tried the MailChimp integration on a test form, but was not able to reproduce any issues.

    Your form seems to be properly configured, but just in case you can try to re-do the integration.

    Also, is there are any failed calls / errors at the bottom of your MailChimp API page?

  • Profile Image

    Answered by h2insurancesolutions on November 04, 2015 at 08:04 PM

    Hi  

    I've had the same issue.  I've set up different API's and disconnected and reconnected quite a few times.

     

  • Profile Image
    JotForm Support

    Answered by Charlie on November 05, 2015 at 03:29 AM

    @h2insurancesolutions

    I opened a separate thread so that we can better assist you, please refer to this link instead: http://www.jotform.com/answers/698131. We will address it shortly.

    Thank you.

  • Profile Image

    Answered by Project1000 on November 15, 2015 at 07:23 PM

    Hi, I thought I responded to this message. There are no errors or fail on the api page.

  • Profile Image
    JotForm Support

    Answered by Charlie on November 16, 2015 at 03:00 AM

    Thank you for updating us. To confirm, the MailChimp integration is still does not work in your end? I just tested it and the new integration wizard does not seem to work properly.

    Here's a screencast, I've created a simple form, in my case, it shows that it is not integrated but when I clicked on it it shows it is already integrated, I tried removing it but it still does not work.

     

    I checked your form and I see that it shows blank in the drop down selection of the form fields. I have forwarded this to our developers to have it checked and fixed. Apologies for the inconvenience. We will update you as soon as the problem has been fixed.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 29, 2015 at 11:54 PM

    @Project1000

    What exactly happens when you try to integrate your JotForm to MailChimp? Do you get any specific error messages?

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 30, 2015 at 02:27 AM

    Hi again,

    We have found out the root cause of the problem and we are working towards a fix.

    We'll send you an update soon.

    Thanks!

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 30, 2015 at 04:02 AM

    Hi,

    The reason the form does not send the data to MailChimp sometimes is because Last Name field is set as required on your MailChimp list, and some of your users do not enter their last names. This causes the API send call to fail. 

    To prevent this from happening again kindly set the Last Name field on your MailChimp as not required.

    Click Lists > Settings > List Fields and *|MERGE|* tags

    Then, unselect the  required checkbox button for Last Name field

     

    On a related note, we'll be implementing a safety net for the sending to succeed even if a required MailChimp field is left empty.

    Hope this helps.

    Kind regards,