What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Visual Report seems to draw data from wrong form

    Asked by lucieleclerc99 on November 24, 2015 at 09:48 AM
    I try to make a visual report, but the data that is inserted come from another form. It's been a few days that this problem persists ...
    visual report visual another form
  • Profile Image

    Answered by Ben on November 24, 2015 at 11:24 AM

    If I understood you correctly, the data that is shown in the Visual Report is being taken from some other form, not from the one that it is being built on.

    If that is so, could you please tell us what is the form where this happens so that we can look into this for you and see the issue that happens and see what could be the reason of the same.

    If it happens on only specific type of the graph on the visual report, do let us know what to look for as well.

  • Profile Image

    Answered by lucieleclerc99 on November 24, 2015 at 11:46 AM
    If I try to make a visual report with the form "Spectacle 2016 - Participation " or with the " TSRN Souper de no 2015 " , it is always the form data " clone of submission and bus transportation Reservation " which appears.
    The problem appears with multiple form
    Lucie Leclerc
    To: lucieleclerc99@hotmail.comSubject: Re: Visual Report seems to draw data from wrong form
    Date: Tue, 24 Nov 2015 11:23:12 -0500
    ...
  • Profile Image

    Answered by Ben on November 24, 2015 at 01:30 PM

    Thank you for the additional details Lucie.

    I took a look at the form http://www.jotformpro.com/form/52968187950976 "Spectacle 2016 - Participation", but when I created the visual report it seemed to pull correct details:

    I have saved the report to allow you to see the data that was shown to me.

    It seems to be pulling its own data, not the data from http://www.jotformpro.com/form/53214418663959 "Clone of Soumission et réservation de transport par autobus".

    Following this, I took a look at the form http://www.jotformpro.com/form/53215906549965 "TSRN Souper de Noël 2015", and after creating the visual report it seems that I was taken to the old visual report.

    So it seems that instead of it taking you to the right - new one, it was actually opening the visual report that you were working on, not allowing you to create a new one.

    I have saved this new one as well, to see what would happen.

    The reports are called "Visual Report - Ben - test" - with [2] being added on the second one, but seems that the name got transferred to the first form.

    I presume that this is an issue with the session data that stores what is the visual report that you are working on. I will raise this to our developers to look into and as soon as it is resolved we will update you about it through this thread.

  • Profile Image

    Answered by SpiritofGeorgia on December 03, 2015 at 09:29 AM

    I just had the same problem. After seeing this I:

    Logged out of Jotform manually.
    Closed my web browser.
    Re-opened browser and logged back in.

    Visual Report now works as expected for my new form. May have to repeat to edit/create another visual report until a solution is made from JotFrom.

  • Profile Image

    Answered by victor on December 03, 2015 at 10:57 AM

    Thank you for the update. By your description, it sound that it could be an issue with the cache or cookies. I will update our team with this.

    If we get any information regarding this issue, we will let you know.

  • Profile Image
    JotForm Support

    Answered by paulsimpson on January 22, 2016 at 05:14 PM

    Hi

    This error has now been fixed. Apologies for any inconvenience caused.

  • Profile Image

    Answered by lucieleclerc99 on January 22, 2016 at 05:45 PM

    Thanks
    --
    Envoyé depuis l'application myMail pour Android vendredi, 22 janvier 2016, 05:14PM -05:00 de JotForm < noreply@jotform.com> :
    ...
  • Profile Image
    JotForm Support

    Answered by Boris on January 23, 2016 at 07:39 AM

    On behalf of my colleagues, you are most welcome. :)

    If you need assistance with anything else, please don't hesitate to open a new support thread about it. We will be glad to help.