credit card filling is disabled because this form does not use a secure connection.

  • Profile Image
    713steve
    Asked on November 25, 2015 at 03:45 AM

    I'm having these exact same issues. When I begin to fill in the credit card number on all of my forms, I get the same message:

    Automatic credit card filling is disabled because this form does not use a secure connection.

    See: http://www.youcallme.org/#!order/cn59 

    The only difference between the above situation and my own is that my forms use Stripe instead of PayPal. Also, the only image that I have within the form is uploaded through JotForm (thus secured by HTTPS).

    As you can see the website link (where the jotform form is embedded) isn't secure by HTTPS, but that shouldn't be the issue as I have always embedded my secure jotform forms within my non-secure sites and never got this message. So what's going on? Is this a JotFrom side issue or a Stripe side issue? Any solution on the way?

    Please answer as soon as possible as this issue is scaring away customers.

  • Profile Image
    Chriistian
    Answered on November 25, 2015 at 04:06 AM

    Hi,

     

    I checked your form - https://www.jotform.com/52215711385956 and I was able to see that there are mixed content being accessed in your form. 

     

    As per checking the form, the issue was due to the value set on the Google Fonts link in the Fit Text widget. The font link was http://fonts.googleapis.com/css?family=Roboto+Slab.

    Please set the Google Fonts link of the Fit Text widget to a secure URL - https://fonts.googleapis.com/css?family=Roboto+Slab and see if it will help fix the issue.

     

    Do let us know if you need further assistance.
    Regards.