can I require (at least) one of three fields?