What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Final Tuition field is not getting the latest value from the Total Tuition field

    Asked by SunbridgeInstitute on January 20, 2016 at 03:49 PM
    the Final Tuition at the bottom of the form is not reflecting the correct Total Tuition value, even though it's calling for it directly. Here are some screen shots:

     

     

    I have temporarily hidden the Final Tuition field because my form is live and I don't want to confuse the users, but I will need to UN-hide it as soon as possible.

    conditions grab value
  • Profile Image

    Answered by Ben on January 20, 2016 at 04:36 PM

    This issue I was able to recreate each time on the following form: https://form.jotformpro.com/form/60143546937964

    However the issue does not seem to be caused by the conditions, but rather by the form saving the previous data.

    For example, go to the field and as it shows wrong info 880 in the screenshot above.. now move to Tuition Subtotal. OK, once there click on it. Now scroll down - value is updated.

    So basically the answer is that either the auto-fill option is holding the old value, or the conditions do not get the to update the correct value.

    I will raise this to our developers, but for now I would suggest leaving the field hidden.

    As soon as there are any updates by our developers in regards to this we would update you about the same here.

  • Profile Image

    Answered by SunbridgeInstitute on January 21, 2016 at 01:24 PM

    Thank you, Ben, for checking with the developers. Since I wrote this question, I have had other instances of the same problem, and I had to rework aspects of the form to get around it each time. For now my form is fine, but it would have been nicer with the original design. Thanks again.

  • Profile Image

    Answered by Ben on January 21, 2016 at 02:49 PM

    Thank you for the update.

    I see that our developer is already assigned to this so he will still be looking to make it work and as soon as it does, we will update you here about it.

    I am however happy to know that you were able to find a workaround for the same.