What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Custom Thank You: HTTP thank you URL not showing a preview of the page

    Asked by FireflyGuy on January 27, 2016 at 04:49 PM

    I have noticed that when I setup a link to direct my viewers after submitting a contact form, the preview page with the editor is blank. It wasn't too long ago that the preview showed me an example of where the the redirect would go. Now it does not. This has caused problems, because I have multiple forms and all needing to go to different thank you links.

     

    Note, I am using MAC with Mozilla Firefox 43.0.4 but this is also not working in IE 11 on a windows machine

     

    What's going on??? Is there a way to preview these links?

  • Profile Image
    JotForm Support

    Answered by EltonCris on January 27, 2016 at 10:16 PM

    Our apologies. The problem is most likely temporary and has resolved by itself.

    When I made a test submission with your form, it is now redirecting to your custom thank you page.

  • Profile Image

    Answered by FireflyGuy on January 28, 2016 at 10:16 AM

    Elton, thanks for your reply, but I guess my post was not clear about the issue. My problem is in the editor and not with the way the form preforms itself. As you can see when I try to preview a thank you page from my website in the editor, the preview page is blank. It used to show me a visual image of the link I was selecting. Now it does not. As you can see, I have dozens of forms linking to dozens of different websites. the visual link, made it easy to confirm that the form was submitting to the correct thank you page on the correct site when submitted. It's not a big issue, just a pesky work around

     

    Thanks

  • Profile Image
    JotForm Support

    Answered by EltonCris on January 28, 2016 at 11:37 AM

    Alright, thank you for the clarification. :)

    I was able to reproduce that problem. It seems the thank you page won't load HTTP URLs due to mixed content error. Since the form builder is on secure URL (HTTPS), the thank page should be on HTTPS as well, otherwise, it will trigger that error.

    So for now, the only solution I could think off is to open the form builder over HTTP. e.g https://www.jotform.com so a preview of the HTTP thank you URL will be shown.

    ---

    No Preview

    Mixed Content Error:

    I have also raised this to our developers for further investigation. You will be informed here for any updates.

    Thank you!

  • Profile Image

    Answered by FireflyGuy on January 28, 2016 at 12:58 PM

    Oh well, the website will only open in the HTTPS environment?? I can not get the non secure site to load. It was working fine up until the end of the year? There has been either some update to your software or how it interacts with the Mozilla browsers. 

    I can work around, I just thought you might want to know about the glitch. Thanks

  • Profile Image
    JotForm Support

    Answered by david on January 28, 2016 at 02:50 PM

    Thank you for bringing this to our attention.  My colleague has opened a ticket for our developers to have a look.  We will let you know here as soon as we have any further information.

  • Profile Image
    JotForm Developer

    Answered by erhan on January 29, 2016 at 11:10 AM

    Hi,

    First of all, we are sorry for the inconvenience. As my colleagues already said, it is not possible to get non-secure content (your thank you url) into secure website (jotform.com) via iframe. Almost all major browsers will block the content when you try to do it. The reason why it was working before might be about that you were displaying jotform.com in http.

    Best.