What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Zoho CRM Integration: Not sending submitted data in some fields to Zoho.

    Asked by rvselect1234 on February 16, 2016 at 10:33 AM

    For some reason I've been able to integrate my two forms with Zoho CRM, but only a few select leads are filtering through. I've redone the integration multiple times and still no luck.

    crm zoho integrate two forms
  • Profile Image
    JotForm Support

    Answered by Kiran on February 16, 2016 at 02:29 PM

    I'm not sure if I understand your query correctly. Do you mean to say that the form submissions are not creating leads in Zoho or are you experiencing any issue while integrating Zoho with your JotForm? Could you provide us with more information on the issue so that we can guide you in the right direction? It would be helpful if you can also provide us with the screenshot of the issue.

    We will wait for your response. Thank you! 

  • Profile Image

    Answered by ppoa on February 16, 2016 at 03:50 PM

    Integration is complete but the form submissions are not creating leads in Zoho. Except for a couple. For example, we've received multiple form submissions from jotforms but only one lead has been created in Zoho CRM today.

  • Profile Image
    JotForm Support

    Answered by BDAVID on February 16, 2016 at 06:45 PM

    I think this is the form you are referring to: http://www.jotformpro.com/form/52795765836979

    The problem might related due to the field mapping. I see that you are using a single TextBox field for the Name field, try replacing it with the "Full Name" field instead, which if found under Quick Tools, it should work best with your integration. 

    Let us know if you need more help.

  • Profile Image

    Answered by rvselect1234 on February 16, 2016 at 07:27 PM

    Okay, I've updated the field to be 'Full Name' and remapped all my integrations to include this. I'll see if it starts to work.

     

  • Profile Image

    Answered by rvselect1234 on February 16, 2016 at 09:32 PM

    Unfortunately leads are still not filtering through.

  • Profile Image
    JotForm Support

    Answered by Welvin on February 17, 2016 at 06:28 AM

    I've cloned your form and was able to submit leads to Zoho CRM. Please try switching your tabs to "All Open Leads" in Zoho. See if all leads are there. Or, try checking Unread Leads.

  • Profile Image

    Answered by ppoa on February 17, 2016 at 02:05 PM

    I checked all categories, including All Open Leads and I have the same two leads sitting in there.

  • Profile Image
    JotForm Support

    Answered by Kiran on February 17, 2016 at 04:00 PM

    Please allow some time to run few tests in this regard and get back to you with relevant information. In the meantime, could you check if it happens with creating a new contact instead of a lead? 

    We will wait for your response. Thank you! 

  • Profile Image

    Answered by rvselect1234 on February 17, 2016 at 07:58 PM

    I seem to have it running okay through Zapier. Though I'm still having issues with an error on some forms due to missing data.

    On a side note, is there any way to arrange so that leads display in the order they are received? (most recent at the bottom or top).
  • Profile Image
    JotForm Support

    Answered by Kiran on February 17, 2016 at 11:14 PM

    Thank you for sharing your findings through Zapier. Let me get back to you once I complete my tests with Zoho integration. The other question is moved to a separate thread and shall be addressed there shortly.

    http://www.jotform.com/answers/775069

    Thank you! 

  • Profile Image

    Answered by Andre Hudon  on February 20, 2016 at 12:41 PM

     If mandatory fields are missing record will not be created 

  • Profile Image
    JotForm Support

    Answered by mert on February 23, 2016 at 04:48 AM

    Alternatively, if you are experiencing some problems on the Zoho integration you can try to import your data using the CSV, XLS file formats. Firstly, you need to get the CSV or XLS format of your submissions on JotForm. Please, check the guide from the link below:

    http://www.jotform.com/help/73-How-to-Partially-Download-Form-Submissions-as-Excel-CSV-PDF

     

    Then, follow the instructions which need to be done on ZOHO CRM,

     

    Please, try this one and let us know the results.

    Thanks.

  • Profile Image

    Answered by rvselect1234 on February 23, 2016 at 01:34 PM

    Hi, I have imported leads in the past but I need to integrate in order to receive leads on an ongoing basis throughout the day from Jotform.

  • Profile Image
    JotForm Support

    Answered by Kiran on February 23, 2016 at 04:14 PM

    I understand. As I tested the integration with my account on my form, I see that the submissions are coming through to the leads without any issues. As I check your JotForm now, I see that Zoho CRM is not integrated to it. I think you must have removed it since you are using Zapier. Could you check if the Zoho integration works properly by using the authentication token method instead of username.

    You may generate the Authentication token by using the link below while you are logged into your Zoho account.

    https://accounts.zoho.com/apiauthtoken/create?SCOPE=ZohoCRM/crmapi

    Also, please make sure that you are selecting the required fields from Zoho to map with the form fields.

    Please let us know if we can be of any further help. We will be happy to assist. 

  • Profile Image

    Answered by rvselect1234 on February 23, 2016 at 07:38 PM

    I re-establish the integration and everything seems to be working...except one field does not seem to be migrating over, even though the exact same field in the other form (there are two) migrates over fine. I deleted and reintegrated a few times for this form, but still no field coming through. Any ideas?

  • Profile Image
    JotForm Support

    Answered by mert on February 24, 2016 at 03:05 AM

    Please, check the related field on the ZOHO integration wizard. It may be forgotten when you set the integration. Please, see it from the below:

     

    After checking the field's availability on the wizard, please do let us know the results.

    Thanks.

  • Profile Image

    Answered by rvselect1234 on February 24, 2016 at 01:25 PM

    Here is a screenshot of the integration. The field missing is 'No of Employees', aka 'RV Year'. Seems to be added and integration fine on the backend.

     

  • Profile Image
    JotForm Support

    Answered by Kevin_G on February 24, 2016 at 04:18 PM

    I cloned your form and I was able to see the issue, as the field "No. of Employees" is numeric I tried to allow only numeric values in the cloned form of yours, it did not work.

    I decided to create a new form and integrate it with Zoho, added a numeric field named "No. of Employees" in my form and still it was not sent to Zoho.

    I will escalate it to our second level, you will receive news about it soon.

  • Profile Image

    Answered by rvselect1234 on February 24, 2016 at 05:09 PM

    Thank you!!

  • Profile Image

    Answered by rvselect1234 on February 26, 2016 at 12:53 PM

    Hi, can you advise if there is any update on this?

  • Profile Image

    Answered by Ben on February 26, 2016 at 02:02 PM

    There are no updates on this at this time, but as soon as there are any our developers will let you know about the same through this thread.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on June 12, 2016 at 01:10 PM

    Hi,

    Apologies for the late update, but we'd like to let you know that this has been fixed. Number of employees field will now be sent properly to ZohoCRM.

    Please do inform us if there is anything else w can help you with.

    Cheers!