What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Account->Users section shows blank page

    Asked by markashton on February 18, 2016 at 09:07 AM

    Hi,

    I tire of notifying you of problems with this product.

    Account > Users > Blank Screen

    What gives??

    No way of doing anything. Tried on both Chrome & FF

    Hopeless.

    Regards Mark

    product FF both sub user account page
  • Profile Image
    JotForm Support

    Answered by Charlie on February 18, 2016 at 01:04 PM

    Apologies Mark, it seems like the API for EU responsible on showing the list of sub account users times out or fails.

    I'll forward this to our back end team to have it checked and fixed immediately.

  • Profile Image

    Answered by markashton on February 18, 2016 at 01:10 PM

    Thanks Charlie,

    Please let me know when done as I need to setup a new user asap.

    Many Thanks

    Mark

  • Profile Image
    JotForm Support

    Answered by Boris on February 18, 2016 at 04:07 PM

    We will make sure to update you as soon as there are any news about it from our developers, Mark. The initial bug report has not yet been assigned to a developer, but it should get assigned shortly.

    When it comes to the issue at hand, I have checked it on my end on both an EU and a non-EU account, and it seems to be working fine at the moment. I have successfully set up a new sub user from my EU account without experiencing any issues.

    I've tested in several browsers just to make sure, and only one time I experienced the same timeout in Chrome that my colleague forwarded in this bug report to our developers, but a simple page refresh made the page working again.

    Could you please check and see if it is working now on your end as well, Mark? Firefox worked on my end without any timeouts.

    We look forward to hearing if it works on your end as well. Thank you.

  • Profile Image

    Answered by markashton on February 19, 2016 at 04:26 AM

    Hi Boris,

    9.20am UK

    Chrome, FF, IE - nothing just a blank screen on all of them.

    Look Boris ... all I ever seem to do is troubleshoot Jotform crap!

    I paid for a year subscription ... and I can't even set-up sub-users ... and now I'm involved in a drama rather than getting on with my business.

    I need to setup a sub-user today. All I get is blank screen.

    What gives? Why isn't someone fixing this as we speak?

    Regards Mark (Your unpaid tech consultant)

     

  • Profile Image
    JotForm Support

    Answered by Boris on February 19, 2016 at 07:18 AM

    The issue is already being worked on by our developers, and we will update you as soon as it is fixed.

  • Profile Image

    Answered by markashton on February 21, 2016 at 05:57 AM

    Great Boris ... but when?

    This is what my client asks me?

    I promised it them.

    You promised it me through your subscription and I signed up for a year.

    Now I find it's not fit for market?

    So ... when?

    How much engineering resource does it take to fix this? Not much I bet.

    Once again I'm cap-in-hand to you lot.

    Come on man ... throw me a bone.

    Thanks

    Regards Mark

  • Profile Image
    JotForm Support

    Answered by BDAVID on February 21, 2016 at 11:35 AM

    Hi Mark, I have sent a message to the Developer in charge of this ticket, hopefully he will respond soon.