Customers are getting a "Please wait" message when they try to submit a form

  • Profile Image
    DININGIN
    Asked on February 24, 2016 at 05:31 AM

    I'm getting complaints from customers that they get a, "Please wait" message when they try to submit a form.  I've tried myself and the, "Send" button changes to, "Please wait".  My website stats show plenty of visitors seeing the forms, but I get no submissions.  My payment form has only worked once successfully when I paid myself 0.01GBP.  The submission test in email settings seems to work OK for each form.  The Catchpa field on one form shows only a spinning wheel so I've removed it.

  • Profile Image
    Welvin
    Answered on February 24, 2016 at 09:45 AM

    Is it the form on this page, http://www.dining-in.com/make-a-payment/? If yes, I was able to submit the form now.

    You are using our iframe method so there should be no problem with this method since this would prevent a conflict which usually cause the "please wait..." message on submit. Did you just re-embed the form? 

    Also, if the above is not the correct page, let us know the correct one so we can check further.

  • Profile Image
    John 
    Answered on February 24, 2016 at 09:55 AM

    Yes - I saw reply to a similar issue and followed the advice re iFrame.  I only just made the change so can't comment if it's working yet.  It was this form and the one at  http://wp.me/P3GLiY-jh

  • Profile Image
    Welvin
    Answered on February 24, 2016 at 11:36 AM

    The iframe should fix it. But if there's still some issues, please update us here so we can check again.

  • Profile Image
    John 
    Answered on February 24, 2016 at 12:09 PM

    Thank you