What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    2. I have a bunch of Hide/show condition fields set up and there are 3 of them that when I click the button required, the field shows up, however if

    Asked by Galecapital on March 16, 2016 at 10:32 PM
    2. I have a bunch of Hide/show condition fields set up and there are 3 of them that when I click the button required, the field shows up, however if I change the answer, the field does not disappear.
  • Profile Image
    JotForm Support

    Answered by Chriistian on March 16, 2016 at 11:48 PM

    Can you please show us the three fields where you encountered the issue? I checked your form and there are a lot of conditions added. It would help us investigate the issue quickly once we know the 3 fields where you had the issue with the Show/Hide condition. You can also add a screenshot of those fields by following this guide: How to add screenshots/images to questions to the support forum?.

    We will wait for your reply.
    Regards.

  • Profile Image

    Answered by Galecapital on March 17, 2016 at 03:46 PM
    Thank you for your quick reply. The three fields are below.
    Ownership/Guarantor Information
    1st. If you add a 3rd owner/guarantor, it is the "Have you ever filed
    bankruptcy" field. If you hit no, everything is fine but if you hit yes and
    then change it, the explain box does not disappear.
    2nd. The same as above but for the 4th owner/guarantor
    Equipment information section
    3rd. Address where equipment will be located field doesn't disappear upon
    clicking “no” after accidentally clicking “yes” to "Is the address where
    the equipment will be located the same as the business address?"
    I hope this makes since, if you have any questions please let me know.
    Jason
    ...
  • Profile Image

    Answered by Huberson on March 17, 2016 at 04:53 PM

    One of the conditions appears to contain a missing field which is the possible cause of the problem. Try to fix this and see if it solves your issue.

     

    Though, I do not fully understand what you need to achieve since you have a lot of conditions that HIDE and SHOW the same fields. I will suggest you use either SHOW or HIDE for most of the conditions unless you are aware that one will not conflict with another - If using SHOW only you can hide the fields you do not want to be visible initially ( When form is loaded ).

     

     If you need further assistance regarding this please let us know. 

  • Profile Image

    Answered by Galecapital on March 21, 2016 at 10:45 AM
    I deleted that missing field and it still has not fixed the problem I am
    having. I have attached the screen shots for one of the sections I am
    having trouble with.
    Section - Equipment Information
    Is the address where the equipment will be located the same as business
    address?
    If yes, the Address Where Equipment will be Located section should be hidden
    If no, the Address Where Equipment will be Located section should be shown
    *If you accidentally check no and then change it to yes, this section does
    not get hidden again.*
    ...
  • Profile Image

    Answered by victor on March 21, 2016 at 11:08 AM

    The screen shot seems it did not get uploaded correctly. I have reviewed your form and noticed that the address fields did hide when changing the options.

    If I am not correct please feel free to correct me.

  • Profile Image

    Answered by Galecapital on March 21, 2016 at 11:45 AM
    I am sorry, I messed with some things before I replied to you and I must
    have not refreshed properly before trying again. Thank you for all of your
    help.
    Jason
    ...
  • Profile Image

    Answered by victor on March 21, 2016 at 11:48 AM

    DO not worry, we are here to help. If you have any other question or issue, please let us know. We will be glad to assist.