my "publish" button is not working

  • Profile Image
    Biblechallenge
    Asked on March 31, 2016 at 09:05 AM

    I am trying to publish a form and the publish button is not working.  I have been using Jotform for several months and it has always worked.

  • Profile Image
    Kiran
    Answered on March 31, 2016 at 11:42 AM

    As I tried to access the Publish wizard, I see that the wizard is opening without any issue now. Could you try logging using a different browser and see if it is working now?

    Please get back to us if the issue still persists. We will be happy to assist you further.

  • Profile Image
    Night45uk
    Answered on May 01, 2016 at 07:05 PM

    Ghostery stops the pop up.   i just found out

    I added Jot form to trusted sites :) love you guys

    so maybe turn off pop up blockers

  • Profile Image
    jonathan
    Answered on May 01, 2016 at 10:31 PM

    @ Night45uk

    Thank you for sharing to us the solution that works for you. Yes, pop-up blocker will most of the time will prevent the Form Builder from working properly since it requires scripts to be enabled on the browser.

    Cheers