What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    How come the direct link doesn't work?

    Asked by TheGPod on March 02, 2012 at 05:14 PM

    I've tried several times to create a direct link to my forms. I went to 'Share & Embed', customized the link, clicked save, and closed the window. 

    I open a new window in Safari and post the direct link, it says 'Invalid Form URL. The form is not available for this domain.' Underneath does words is a link (jotform.us.form/20615783270149) that connects me to my form. 

    What am I doing wrong?

    Thanks in advance.

    Page URL:
    www.jotform.com/TheGPod/ORS

    Screenshot
  • Profile Image

    Answered by anartwork on March 02, 2012 at 07:13 PM

    Please check the link you pasted. I checked the link and it actually worked. Based on your post above, you mentioned that the link was "jotform.us.form/20615783270149" but then it should be "http://www.jotform.us/form/20615783270149". Please note that the .us is followed by "/" not by a "."

     

    Hope this helps :)

  • Profile Image

    Answered by TheGPod on March 05, 2012 at 11:12 AM

    Hi anartwork, 

    Thanks for your response. I know that the link from JotForm with all the numbers works. The custom link that I created is not working and always directs me to the 'Invalid Form URL' page (please see screen shot above). 

    I'm trying to figure out why my custom link (www.jotform.com/TheGpod/ORS) does not work. 

    Thanks again. 

  • Profile Image

    Answered by Aurora88s on March 05, 2012 at 11:30 AM

    I am having this same problem.  I make the custom URL, and then when I copy and paste it into my browser, I am getting the same error.  

  • Profile Image

    Answered by pinoytech on March 05, 2012 at 11:33 AM

    Hi,

    Try to used this custom link: http://www.jotform.us/TheGpod/ORS I think the reason you got an error on your custom url because you are using .com instead of .us.

    Thank you!

  • Profile Image

    Answered by Aurora88s on March 05, 2012 at 11:36 AM

    Yeah, I just figured it out.  The URL listedn in the "Embed Form" window is incorrect.  It says "www.jotform.com/myinformation", but it really should be jotform.us.   So I can't just copy the direct link from the Embed Form window.   that's the problem.

  • Profile Image

    Answered by pinoytech on March 05, 2012 at 11:41 AM

    @Aurora88s,

    Cheers! I am glad that you figured it out.

    For further assistance or concernce, feel free to contact us!

    Thank you for using JotForm!

  • Profile Image

    Answered by serkan on March 05, 2012 at 11:57 AM

    There was a problem on share wizard, it's fixed now. Please re-open the wizard get the correct link.

    Thanks for reporting.