What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Email Alerts: Cursor moves to end of the text, when entering the subject on edit mode

    Asked by mgcaledonian13 on April 07, 2016 at 11:40 AM

    When editing the text in the Notification the cursor appears to act as if I have pressed the "End" key on the keyboard. This does not happen anywhere else, so key is not jammed down.

    Is this a bug or am I doing something wrong?

    Screenshot
    end cursor in the notification OR in
  • Profile Image
    JotForm Support

    Answered by BJoanna on April 07, 2016 at 12:50 PM

    I was not able to replicate mentioned issue on my form when I was editing the text inside of email Notification.

    I have also checked email Notification of your form and I saw that you deleted the table and that you added custom text inside of your email Notification.

    Were you able to resolve you issue? If the issue persist, please try using different browser, to see if that will resolve your issue.

    Feel free to contact us if you have any other questions. 

  • Profile Image

    Answered by resortvacations on April 07, 2016 at 04:39 PM

    I have been trying everything I can think of for the past few days to find a way to resolve this and have been extremely frustrated. I have tried it on every browser I can think of. In my case, I am only having the issue on mobile devices- Windows tablet and Android tablet. I have tried Chrome, IE, Edge... Same thing. It occurs for some reason when I am trying to use the telephone number with input mask validation. I always need to manually place the cursor back at the beginning of the text input field. And if I don't place it after the left parenthesis for the area code mask, it prepends the entry for the phone number and forces the entire entry to the right. I don't have issues like this with the desktop computer environment, only mobile. Thank you for your time.
  • Profile Image
    JotForm Support

    Answered by Boris on April 07, 2016 at 05:02 PM

    @resortvacations, as your message is describing a different issue and in order for us to assist you better, it has been moved to a support thread of its own:

    https://www.jotform.com/answers/813267

    We will be answering you there, shortly. Thank you.

  • Profile Image

    Answered by mgcaledonian13 on April 07, 2016 at 07:23 PM

    Hi BJoanna

    I think maybe I did not explain this correctly or you may have missed the fact as the bit I want to edit loses focus.

    Found a animation recorder and I have attached a copy of it to this reply . I hope it works.

    You can see the Cursor moves to the end of the line every time I insert a character.

    This animation recorder was a great find called ScreenToGif 

     

  • Profile Image
    JotForm Support

    Answered by liyam on April 07, 2016 at 11:23 PM

    Thank you for the animated GIF, mgcaledonian13. It definitely explains what's wrong. With this, I have submitted a ticket to our development team and have them look into this matter. Once this matter is fixed, we'll let you know.

    Thanks.

  • Profile Image

    Answered by mgcaledonian13 on April 08, 2016 at 03:14 AM

    Liyam

    Thanks for your concern.

    I suppose that I could live with it, but it may confuse a new client and anyway it is not right, am I the only one with the problem?

    Willy Scott 

  • Profile Image

    Answered by mgcaledonian13 on April 08, 2016 at 03:15 AM

    Ooops!

  • Profile Image
    JotForm Support

    Answered by beril on April 08, 2016 at 04:15 AM

    I've cloned and tested your form I am not able to reproduce the same issue that you're having. I am abel to change the title of email.

    Can you try to create a new autoresponder for testing?

    If it doesn't solve your problem, please let us know. We will be happy to assist you.

     

  • Profile Image

    Answered by mgcaledonian13 on April 08, 2016 at 04:25 PM

    No I am sorry that has not solved the problem. A Cloned a form and a completly new Form  do exactly the same. Change of browser does not make any difference either.

    Willy Scott

  • Profile Image
    JotForm Support

    Answered by BDAVID on April 08, 2016 at 06:04 PM

    This issue has been reported to our development team, you will be notified via this thread about any updates on this matter.

  • Profile Image

    Answered by mgcaledonian13 on April 09, 2016 at 05:03 AM

    Thanks, I will wait patiently for the up date.

    Not often things go this wrong but these things happen.

    Also it is not life threatening !!

    Willy Scott 

  • Profile Image

    Answered by Carina on April 09, 2016 at 06:34 AM

    Thank you for your patience. This ticket was already assigned to a developer and was considered priority. We'll contact you as soon as we have more details.

    Let us know if we can assist you further.   

  • Profile Image

    Answered by mgcaledonian13 on May 19, 2016 at 02:23 AM

    Have you managed to solve this problem at all.

    It is a little annoying but not critical.

    Willy Scott

  • Profile Image
    JotForm Support

    Answered by EltonCris on May 19, 2016 at 04:08 AM

    @mgcaledonian13

    Sorry but there is still no update about this.

    The ticket is still assigned to our developer. They are working on another project right now but as soon as they get into this and the issue is resolved, you will be informed via this thread.