Seems that the form is backtracking

  • Profile Image
    comptamanager
    Asked on May 18, 2016 at 05:41 AM

    Hello, 

     

    I try to do (a lot of) modifications on an old form but i've a lot of problems/errors. It seems that the form lost all conditions. Thanks to the historic of version i can get back all my work, but it continue to append (3-4 times in 15 minutes), and each time I lost my work ....

     

    Furthermore, I experiment very odd behavior for my form (things appear when I don't ask anything, and things disappear when I ask them to appear ....).

    So, do you have an idea of why my form is backtracking , and also if there is some compatibility problems between old form create last year and now ?

     

    thanks in advance

     

  • Profile Image
    Charlie
    Answered on May 18, 2016 at 10:32 AM

    Are you editing the form using multiple windows and opening them in multiple form editors? If so that will cause problems in your end to what session and changes will be saved.

    Another issue is that the form is quite long and it actually has 190 conditional logic. Here's a screencast of it:

    The form should still work, given if the conditions are setup properly and there are no conditional logic conflicting one another. 

    So far the only possible issues that I'm seeing are the length of the form and the number conditions (that may be conflicting). Other than that, I can still use the form builder and edit the form without any problems. Perhaps you could share us a specific problem you are experiencing and the steps on how to replicate them?

    We'll wait for your response.