Embedded form on my WP site won't submit

  • Profile Image
    ericaperel
    Asked on June 01, 2016 at 12:12 PM

    I created a simple form and embedded it into a wordpress site.

    When you get to the submit button, you get a "Please wait" for forever.

    The form submits just fine from the direct form link. this is only happening with the embedded version of the form. I have used embedded jot forms many many times before, so I'm not clear why this is happening.

     

    Here is he form: https://form.jotform.com/61508210808147

  • Profile Image
    EltonCris
    Answered on June 01, 2016 at 12:40 PM

    Could be due to script conflict.

    Before we will dive into troubleshooting the problem on your page, we suggest to re-embed your form using iframe embed code. Since the form will load directly into the iframe container, it will not conflict anything on your page. This should also fix the problem.

    Please let us know how this goes. Thank you!

  • Profile Image
    ericaperel
    Answered on June 01, 2016 at 01:20 PM

    Wordpress doesn't seem to recognize the iframe embed code. When I paste it into the page, it just shows up as code. What I'm using the the specific wordpress code y'all provide.

     

  • Profile Image
    Mike
    Answered on June 01, 2016 at 02:14 PM

    If you use a self-hosted wordpress version, please try with a code for WordPress.org platform.

    We have a video instruction that can be accessed by the next link:

    https://vimeo.com/144260113

    Related guide:

    Adding Forms to Wordpress.org version

    If this does not help, please let us know.

  • Profile Image
    ericaperel
    Answered on June 01, 2016 at 09:43 PM

    Sorry, I was using the wordpress.org code to begin with.

  • Profile Image
    Kevin_G
    Answered on June 01, 2016 at 11:08 PM

    Not sure if the issue is still there, if form is still stuck on please wait when trying to submit it, please do let us know, also provide us the link where your form is embedded that would be helpful. 

     

  • Profile Image
    ericaperel
    Answered on June 02, 2016 at 11:22 AM

    It's still stuck on please wait.

    For some reason, when I tried to re-embed the wordpress.org code, the browser wouldn't recognize/embed it. It will recognize the wordpress.com code, but it won't allow you to submit.

     I have successfully embedded jotfoms on this site previously using the wordpress.org code.

    Here's the link to the page it's on.

    http://alumni.dailytarheel.com/summer-networking-events/

  • Profile Image
    Mike
    Answered on June 02, 2016 at 12:52 PM

    Have you tried embedding the Embed/iFrame code into a Text tab?

    It does work on my end. Please let us know how it goes.

  • Profile Image
    ericaperel
    Answered on June 02, 2016 at 01:37 PM

    Okay, seems to be working right now. Hopefully it will stay that way. Thanks!!

  • Profile Image
    Kevin_G
    Answered on June 02, 2016 at 01:49 PM

    On behalf of my colleagues, you're welcome. 

    Good to know it is working now, please do let us know if there is anything else that we can assist you, we will be glad to help.