What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Adding New Filter to a Visual Report causes it to get stuck on loading

    Asked by VailClub50 on June 16, 2016 at 12:08 AM

    All of our Visual Reports are displaying no data.  Here's an example:

    https://www.jotform.com/report/61289352323051

    I noticed that there was a recent issue with Visual Reports for a database with more than 100 submissions.  We just got our 101st submission recently, so perhaps that issue still exists?

    If I try to edit one of our Visual Reports, I get this error message:

    Fatal error: Class 'Reports\Filters\AnswersDB' not found in /www/v3/live/lib/classes/Reports/Filters/Answers.php on line 27

    Page URL:
    https://www.jotform.com/report/61289352323051

    Reports visual reports visual
  • Profile Image
    JotForm Support

    Answered by jonathan on June 16, 2016 at 12:38 AM

    I checked the report https://www.jotform.com/report/61289352323051 and it also shows empty on my end.

     

    Have you tried creating a new Visual report for the form? 

    If not, can you please try the option also. I did test it, and it was showing data on the new report.

     

     

    We wll wait for your updated response.

  • Profile Image

    Answered by VailClub50 on June 16, 2016 at 08:35 AM

    Creating a new Visual Report sort of worked.

    I was able to click Add New Report, and to configure the fields I wanted to exclude.  But when I try to add a filter, the form locks up as per the screen shot below.

    Also, I've got 15 existing Visual Reports, and frankly, they're a lot of effort to create (you need to EXCLUDE the dozens and don't of fields that you DON'T want, rather than specify the few fields that you do want).

    So even if I could create a new Visual Report, I really don't want to do that -- I'd like my existing reports to start working again :-)

     

  • Profile Image
    JotForm Support

    Answered by KadeJM on June 16, 2016 at 10:34 AM

    We appreciate your attempt at creating a new visual report and thank you for the additional details about this issue you are experiencing.

    Please allow us some time to investigate this issue a bit deeper and so that we can help you better with this problem and we'll update you again as soon as we can.

  • Profile Image
    JotForm Support

    Answered by KadeJM on June 16, 2016 at 11:48 AM

    Upon further testing I found I can replicate this problem several times in a row after a few tests.

    Everything looks okay up until you apply a filter then it appears to fail and get stuck on loading as you've previously mentioned above being the problem.

    I've sending a bug report about this problem on your behalf with this thread to our developers to get this problem looked into as soon as possible. 

  • Profile Image
    JotForm Support

    Answered by paulsimpson on June 16, 2016 at 05:27 PM

    Hi

    This problem has now been fixed. Apologies for the inconvenience

    Regards

    Paul