Our web developer partner is having issues with form code we sent

  • Profile Image
    neha2010
    Asked on November 08, 2010 at 02:30 PM

    See below - several issues on the following forms we're working on:

     

    http://stage.healthyhomesconference.org/early-participant-registration.htm

    http://stage.healthyhomesconference.org/participant-registration.htm

    http://stage.healthyhomesconference.org/presenter-registration.htm

    http://stage.healthyhomesconference.org/student-registration.htm

    http://stage.healthyhomesconference.org/other-registration.htm

     

    http://stage.healthyhomesconference.org/non-profit-exhibitor-registration.htm

    http://stage.healthyhomesconference.org/corporate-exhibitor-registration.htm

     

     From web developer partner: The Early Participant Registration form that we received had some problems (missing inputs and submit button) so we created a new version of the form based on the Participant Registration form,  using code from the original form so that it goes to the correct JotForm input, and shows the correct $300 cost to Paypal. The one thing with this form is that there is a CAPTCHA field that we’ll need removed, that I believe is managed within JotForm.

    http://stage.healthyhomesconference.org/early-participant-registration.htm


    Response from me/JotForm account holder:

    Captcha is not showing up in the design via the JotForm admin interface Early Participant form http://www.jotform.com/neha2010/2585945300 …but I ran a test on your version of the form, and see what you mean re: the captcha showing up on submit; I also tested my copy of the form via preview in JotForm and this problem did not appear.  I will need to send follow-up to JotForm on this to see what their developers say might be causing it in the customizations your team did to your version of the form, and how to fix it.

    NOTE: I did see one thing on the earlybird form submit code on your end that made me think it could be causing the glitch – technically shouldn’t have an effect, but lord knows I’ve seen stranger things ‘cause hiccups like this in scripting: the earlybird form does have the regular participant form code commented out on the back end.  Have you tried removing the tags for form 305 altogether on the earlybird form and testing?    If not, can you try that?  I will let you know what JotForm comes back with regardless.

    The developer is also reporting the following (*his comments and mine are included:

    1.)   ·         There is a problem with the Non-Profit Exhibitor Registration form (http://stage.healthyhomesconference.org/non-profit-exhibitor-registration.htm). Specifically, when a user wants to pay by credit card and selects a number in either quantity dropdown, the total on the Paypal page is not accurately reflected. Let’s say the user clicks both checkboxes for exhibitor registration ($800 per) and additional attendees ($300 per). When selecting a value of more than 1 person in each dropdown, the total carried over to Paypal only reflects as though the user had selected 1 in each drop down – essentially meaning the user is under charged. Please note that this functionality does work correctly for the Corporate Exhibitor Form, so I think we should be able to resolve this.

    ·         Not able to recreate this problem – can you run a test and send over a screen cap like below?

    2.) ·         The biggest technical concern (that may require guidance from JotForm) is that the javascript validation for required fields does not work in Internet Explorer (7 or 8). It does work fine in Firefox and Chrome. As a result a user in IE can not only leave vacant fields, but can submit a completely blank form. My developer suggested that perhaps the Javascript library being used by JotForm (Prototype) is newer than IE can support. Either way, with the majority of our users likely to be using IE, we’ll naturally need to get this resolved.

    ·         I agree that this could be a big concern, but again: I’m not able to recreate when I test with IE 8?  See screen cap below, and send screen caps from that end if possible.

    Again, will still send this in to JotForm along with the Captcha issue.  Please keep in mind that normal turn-around on tickets with JotForm developers is about 24 hours, so we are somewhat at their mercy on how quickly they get back.  

    Lots of issues, two of which I can't re-create, but definitely need assistance from JotForm to help get these bugs worked out - can your team help?  

    Thanks,

    Dajana

  • Profile Image
    aytekin
    Answered on November 09, 2010 at 07:04 AM

    Unfortunately, the forum is not suitable for this kind of threaded discussion. Please post separate questions on separate forum threads.

    - You can remove the captcha field from the form builder. Just select the captcha question on the form builder and click on the delete icon.

    - The quantity problem does not happen on the original form. I select 2 as quantity and the PayPal page asked for $1600. So, the form code on your site might have a problem. You might want to update the code with a new clean version.

    - I also tried the original form on Internet Explorer 7 and they worked fine. This also might be because of the problem with copying the code. Updating the form code on your site might also fix this.

  • Profile Image
    neha2010
    Answered on November 09, 2010 at 07:47 AM

    Okay - I will submit separate questions with individual issues as we work thru them.  

    The key issue that I can't give the developer direction on is the captcha issue.

    The captcha problem is unique - it does NOT appear on the form (*so I can't delete it on the original, or instruct their team to delete it on their end), nor can it be seen anywhere within the code; it is upon clicking "Submit" on the form that the re-direct goes first to a screen with captcha, then forwards the user to PayPal.  Have you seen this issue before?  Could this be caused by their customizations to the code?  They commented out the following in the source of their form:

     <form class="jotform-form" action="http://www.jotform.com/submit.php" method="post" name="form_2585945300" id="2585945300" accept-charset="utf-8">

    <input type="hidden" name="formID" value="2585945300" /><!-- <form class="jotform-form" action="http://www.jotform.com/submit.php" method="post" name="form_2644004305" id="2644004305" accept-charset="utf-8"> <input type="hidden" name="formID" value="2644004305" /> --> <div class="form-all">

    Page for reference is located at:

    http://stage.healthyhomesconference.org/early-participant-registration.htm 

  • Profile Image
    aytekin
    Answered on November 09, 2010 at 11:10 AM

    It is happening because the form ID is changed on the form tags but it is not changed on the javascript code at the end of the form. The form ID should also be changed there. That javascript is used to make sure the form submitter is not a spam bot. You will need to also change the form ID there.