Page Break Problem: Jump to Top of Page on NEXT/BACK Button Click not Working

  • Profile Image
    antoniooi
    Asked on April 03, 2012 at 06:16 AM

     

    Hi Guys,

    Any new development for this behavior since it was like last year ago? I need the next page to jump to the top on the NEXT button click because:

    1. Page 2 is long, page 3 is short.

    2. When users click NEXT on page 2, they see NOTHING on page 3, as though something has gone disappeared.

    3. Users have to manually scroll up to discover the existence of page 3.

    Likewise, when Page 1 is short, clicking the BACK button from Page 2 will lead to nothing appear on Page 1 unless the users scroll up to the top of the page.

    But I remember that this behavior may affect lightbox if I'm not mistaken. Let me know if we can inject some javascript to achieve this behavior ourselves, but of course for those that embedded with iFrame only. By the way, how about the full source embed? Why is it being disabled? FYI, my form has FB and PayPal integration too.

    P/S: FXR suggested me to use "?nojump" on my code but it still doesn't achieve what I want, that is to jump to the top of the page. But please beware of the Lightbox as this feature may not be desireable for Lightbox.

    Thanks.

    Antonio

  • Profile Image
    aytekin
    Answered on April 03, 2012 at 07:52 AM

    We have assigned this to one of our developers. We will work on it and let you know. 

  • Profile Image
    ywammadison
    Answered on April 04, 2012 at 03:43 AM

    I second this request! We have users who think their forms disappeared and they lost everything when they go to "next" or sometimes to "submit."

    Thanks for all your great work.

  • Profile Image
    battlechop
    Answered on April 21, 2012 at 10:04 PM

    +1

  • Profile Image
    antoniooi
    Answered on April 22, 2012 at 07:47 AM

    LOL.... :D Ask JotForm to add a +1 button here then, easier to vote. :D

  • Profile Image
    raganlawfirm
    Answered on April 24, 2012 at 04:10 PM

    +1 - Need this functionality here also.

  • Profile Image
    ignitead
    Answered on April 27, 2012 at 03:41 PM

    +1 We need this!

  • Profile Image
    interknecht
    Answered on June 05, 2012 at 06:59 PM

    Any update on this fix?

  • Profile Image
    jeanettebmz
    Answered on June 05, 2012 at 07:18 PM

    @interknecht

    I have sent a message to the assigned developer to get an update on this ticket

     

    Cheers!

    Jeanette

  • Profile Image
    ywamharpenden
    Answered on July 13, 2012 at 06:29 AM

    I'd also like to know if there's been any improvement/workaround for this problem?

    Thanks

  • Profile Image
    antoniooi
    Answered on July 13, 2012 at 07:18 AM

    Well...it seems like JotForm is following the footstep of Google whereby important user feedback is ignored while keep focusing on their new cloud integration releases..... @_@

    Please JotForm team.....please do something.....this is like 4 months ago already or even longer.... :(

  • Profile Image
    liyam
    Answered on July 14, 2012 at 03:14 AM

    Hello anoniooi.  As of yet, we have not yet heard from the developer for updates on this matter.  Rest assured that as soon as we have updates, we'll immediately update this thread.

    Thanks for your patience.

  • Profile Image
    financejunction
    Answered on August 14, 2012 at 12:37 PM

    I could really do with this being fixed also, it's such a simple thing yet it really lets jot form down. I appreciate that it may not seem important in the scheme of things, however most people are reluctant to fill in web forms at the best of times and this small bug can have a massive effect on a websites conversion rate. 

    Is there any update on this please? 

  • Profile Image
    Mike_T
    Answered on August 14, 2012 at 06:10 PM

    That bug report ticket is still in Developer's queue. Please accept our apologies for the delay on this.

    Probably I am missing something, but I have just tried to reproduce the problem, and I was able to do it only in Chrome with iFrame based form.

    Is there any way that you can try to use either standard Javascript Embed Code or form Source Code embedding option?

    Thank you for your patience in this matter.

  • Profile Image
    antoniooi
    Answered on August 15, 2012 at 02:59 AM

    I thought your forms with FB integration only allows iFrame embed?

  • Profile Image
    liyam
    Answered on August 15, 2012 at 07:05 AM

    Hello antoniooi.  After Facebook stopped the support for FBML, the only solution to embed forms in facebook pages then was to embed via iframe.  It was only recently (a few months back) when we found another solution via embedding using facebook developer method. 

    You can check the steps on how to embed forms in facebook pages via Facebook Developer on this user guide.

  • Profile Image
    atlasadvisors
    Answered on August 17, 2012 at 04:45 PM

    This happens to me in Chrome (maybe other, but I only use Chrome) regardless of how its embedded (javascript/source/iframe, doesn't matter).  It's ridiculously annoying.   

  • Profile Image
    Mike_T
    Answered on August 17, 2012 at 05:57 PM

    @atlasadvisors,

    Can you please share a link with us? It may be helpful for our Developers.

  • Profile Image
    ywamharpenden
    Answered on September 21, 2012 at 11:13 AM

    I am still haveing the same problem in Chrome on a Mac. I tried in Firefox and it seems to jump back to the top. This is using a javascript embed code.

    This has been quite a while waiting for this. Is there any update coming to resolve this issue?

  • Profile Image
    jeanettebmz
    Answered on September 21, 2012 at 01:54 PM

    @ywamharpenden

    I have sent another note to our dev team so they can assign a higher priority to this feature request

    We appreciate your patience on this

  • Profile Image
    petitamuse
    Answered on December 18, 2012 at 07:45 PM

    +1  It looks like this issue has been outstanding for a VERY LONG TIME.  It would be great if it were finally resolved.

  • Profile Image
    jeanettebmz
    Answered on December 18, 2012 at 07:51 PM

    @petitamuse

    Can you please open a separate thread with the same title if possible? This way I will open a new ticket  for our developers so they will know there is an urgency on this matter

  • Profile Image
    ozan
    Answered on January 02, 2013 at 08:33 AM

    Hi all,

    We've finally fixed this issue. But please notice that the iframe embed code should be updated to fix this problem. Sorry for the delay.

  • Profile Image
    NKJINC
    Answered on January 22, 2013 at 10:58 PM

    What was the fix? When I use the script I stay at the bottom of the page. When I use Iframe, I have a huge white space at the bottom of the page. 

    Can someone explain where there was a fix?

  • Profile Image
    pinoytech
    Answered on January 22, 2013 at 11:16 PM

    @NKJINC

    Can you please share to us the URL of your website where your form embedded to investigate the said issue for further assistance?

    Thank you!

  • Profile Image
    openawards
    Answered on February 06, 2013 at 04:27 AM

    I am also having this problem with a javascript embed code in Chrome - it's fine in Firefox/IE though. The URL of the page is http://tinyurl.com/b2x7ekl

  • Profile Image
    jonathan
    Answered on February 06, 2013 at 08:03 AM

    @openawards

    Hi, will it be OK for you to use your form's iframe code instead? I see that you are using the script javascript code already.

    Please try iframe first, and inform us if this does not resolve your issue.

    Thanks.

  • Profile Image
    openawards
    Answered on February 06, 2013 at 09:54 AM

    Hi,

    Yep, that's fixed the problem. Will there be a fix for this error in the javascript code soon though?

    Thanks!

  • Profile Image
    EltonCris
    Answered on February 06, 2013 at 10:27 AM

    @openawards,

    Glad to hear it's fixed now. 

    The mentioned problem doesn't occur on Firefox when embedded as javascript embed code but it appears to be a problem on Chrome as previously mentioned by Mike and base on my test just now. I'm sure our dev team are made aware of this already. So hopefully, there will be an updates to counter the said issue on Chrome soon.

    Thanks!

  • Profile Image
    sbrads9792
    Answered on July 31, 2017 at 05:31 AM

    5 years after this thread and I have the same problem. The form on my iphone does not go to the top of the next page

     

    Steve Bradshaw 

    sbrads9792@aol.com

  • Profile Image
    Nik_C
    Answered on July 31, 2017 at 11:18 AM

    @Steve,

    I opened a separate thread and we will attend it here: https://www.jotform.com/answers/1211958

    Thank you!