What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    My form must do two things-send us an email and go to a custom URL page. For some reason it fails to point to this page.

    Asked by garyleosmith on April 06, 2012 at 11:45 AM

    The embedded code you provide seems to ignore the .html suffix on the page address. I've re-embedded the code multiple times, even tried another URL. Remade the form. Nothing works.

    Page URL:
    http://www.trymailnet.com

  • Profile Image

    Answered by fxr on April 06, 2012 at 12:26 PM

    It working fine here. 

    I filled out the form and it redirected me to http://trymailnet.com/thankyoumailnet.html

    Can you please try clearing your browser cache or even doing a test on a different browser to see if the problem persists? 

    Everything seems to working well on the form here. 

  • Profile Image

    Answered by garyleosmith on April 06, 2012 at 12:50 PM

    We tried on 3 different machines and 3 different browsers. No luck. Your link in the answer email DOES go to the correct page, and we received your test email. ?????

  • Profile Image

    Answered by garyleosmith on April 06, 2012 at 01:12 PM

    We just reexamined the conditions setting for the overall form. It was wrong, and apparently overriding the "submit" button setting, which was correct. It works now. Still wonder why it worked for you before it was corrected?

  • Profile Image
    JotForm Support

    Answered by Goldo on April 06, 2012 at 01:34 PM

    As fxr stated, it was working his end, I'm not sure why it's not on your end that time. However, I'm glad it's working perfectly now. If you happen to encounter same issue, please let us know so we can have a deep look to it. Thanks!