What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Stripe failed payment not updating the quantity when navigated back

    Asked by newwheel on August 22, 2016 at 03:27 PM

    Hey there!  Can you please email nate@newwheel.net with the response to this thread? 

     

    Trying to test payment on a form integrated with Stripe.

    Here's what happens.  I complete my form, use fake cc and CID (4242..., 123), and I get an error (see screenshot).

    When I 'reenter payment' as prompted on error screen, I can reenter same cc as above, and payment will go through, however the qty of inventory item on the page that generated the payment amount disappears (though payment amount remains on the reloaded form).  Unfortunately, the form submission becomes unusable as I don't know what item customer has ordered.

    Alternatively, I can get payment to go through by reentering fake cc above and selecting the product again (though a customer would never know to do this, since payment total remains correct on reloaded form).

    1) I have let widget automatically connect with Stripe and selected test mode

    2) I have manually connected to Stripe using the private and public test api keys.

    At this point, I don't feel confident that this form will work, and the only way to truly test it is to run an actual card.

    Here are my needs:

    A) Is there a way to get a normal/expected response from the form test mode?

    B) When form reloads it would be good to have it be either blank or have the product selected and the correct deposit value.  To have no item selected but a deposit in place is confusing.

    Thank you!
    Nate

    nate@newwheel.net

    Page URL:
    https://www.jotformpro.com/form/62299112139961?preview=true

    Screenshot
    test mode stripe test mode product integrated card selected
  • Profile Image
    JotForm Support

    Answered by Kiran on August 22, 2016 at 05:41 PM

    Please be noted that the forum responses will be sent automatically to the account registered email address.

    Since the Inventory widget is loaded using an iframe, the value selected cannot be restored when the browser is navigated back. I have tried cloning your JotForm to my account and tested with my Stripe test account. When I tried to submit the form, it went fine.

    Please be noted that it is required to authorize the Stripe test and live accounts separately before you test them with an actual submission so that the form should process the payment. If there is any issue with the credit card, it validates on the form itself.

     

    Please try authorizing the Stripe account by selecting Live/Test mode separately and then test by sending a new submission. It should be working fine. Please check and let us know if you need any further assistance. We will be happy to assist. 

  • Profile Image

    Answered by newwheel on August 22, 2016 at 06:19 PM

    I just set Stripe in test mode, tested the form, got same error.


    I cloned the form, put Stripe in test mode, tested the form, got same error.

     

    I tried using both  'Stripe Connect' (in test mode), and the test API keys.  No difference.  Can't get an order to go through on first try...

     

    Would you mind testing our form directly (it is in test mode, so try 4242424242424242 / 123).

    See if you get the error?

     

     

  • Profile Image
    JotForm Support

    Answered by Kiran on August 22, 2016 at 07:27 PM

    I have tried submitting your JotForm twice using the test credit card number and I am able to see the Thank you page on the first attempt for both submissions.

    Could you try once again using a different browser and let us know if the issue still persists? 

  • Profile Image

    Answered by newwheel on August 22, 2016 at 10:57 PM

    Same on Firefox and Safari under all conditions I can think of to change.  FF v 48.0.1, S v 8.0.8

    Here's an interesting thing to note - when I get the error, and click on "Go Back to Fix" - if I reenter the CC number (4242..) and CID (123), whether or not I reselect the bike I want to reserve (the deposit for $500 remains there regardless), the test payment goes through every time. 

    It always fails the first time, always goes through the second.

    I trust that this is just on my machine, so I'll go live with the form.  I really appreciate your help, please let me know if you learn anything new.

    Love this product, and really appreciate the prompt support.

    Yours, Nate

    nate@newwheel.net

  • Profile Image
    JotForm Support

    Answered by liyam on August 23, 2016 at 12:52 AM

    Hello Nate,

    Can you try disabling your autofill settings on your form and let us know if the problem persists? I'm suspecting your old browser cache is causing the error.

    Thanks.