What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    The Update/calculate field Conditions: the form is not loading due to TypeError: e.split is not a function error

    Asked by info@pdfn.co on August 23, 2016 at 02:48 AM

    I am working on a form https://eu.jotform.com//?formID=60495657166365

    about since a day or two ago, when opening in preview (or view) the form does not load fully, previously it worked just fine. ff offers to debug some script, chrome crashes and requires to kill the site.

    Another form works fine.

    Making a clone of this did not resolve the problem.

    Can you please advise what could be the problem? Thanks

     

    Page URL:
    https://eu.jotform.com//?formID=60495657166365

    opening form JotForm problem preview another form
  • Profile Image
    JotForm Support

    Answered by beril on August 23, 2016 at 03:52 AM

    I've checked your form on FireFox and Chrome. I am able to reproduce the same issue on my side. It so slow.

    I think it is related to your conditions. There might be a conflict between your conditions. I've cloned and disabled all of your conditions. At that time, it worked properly on my side.

    Could you please provide us more information about your calculations? At that time, we can check it better. We will wait for your response.

  • Profile Image

    Answered by info@pdfn.co on August 23, 2016 at 06:46 AM

    But the form has been tested number of times and up till last week worked perfectly fine. Conditions are the core of form as they avoid calc mistakes... Is it possible to define which one causes problem?

     
    Have you changed core system lately which could cause such problem?
     
    There is also an internal script insode that hides fields using em... Could that be a problem?
     
    Thanks
  • Profile Image

    Answered by info@pdfn.co on August 23, 2016 at 07:26 AM

    FF displays this when debugging - if it helps...?

     

     

  • Profile Image
    JotForm Support

    Answered by beril on August 23, 2016 at 08:01 AM

    Thank you for providing the JS error. I also checked that on FireFox. I am getting different errors on my side.

    Did you update your conditions recently? If it is yes, we would appreciate it if you could provide us the conditions that you've updated last week. I will also check your conditions deeper and try to find the cause of that issue.

  • Profile Image

    Answered by info@pdfn.co on August 23, 2016 at 08:02 AM

    we did not change anything and form worked perfectly with over 100 test calculations in past month

  • Profile Image

    Answered by info@pdfn.co on August 23, 2016 at 11:50 AM

    is there a possible problem in update of java? interresting though, that same thing happens on both win and osx ... 

  • Profile Image
    JotForm Support

    Answered by KadeJM on August 23, 2016 at 01:11 PM

    Thank you for the additional information about that.

    If it's related to java on your end then it's recommended to make sure your computer's java is kept up to date including your browser version as both of these can affect it if left as obsolete.

    However, after looking at this with issue on my end with my recently new win and mac computers I don't think your java is the cause of the issue since I can replicate this problem on my end.

    It seems that something was added to the form causing a conflict which is probably the result that you are seeing with it not opening  nor responding.

    So I'll be helping to assist with investigating the issue further so that we can get this problem resolved for you as soon as possible.

    You mentioned you haven't changed anything and it worked fine before so you mean that you didn't change anything prior to this problem occurring then correct? It just happened somehow when you went to use it not too long ago then?

  • Profile Image

    Answered by info@pdfn.co on August 23, 2016 at 01:41 PM

    Exactly, no one touched form source. Problem must be within core system since problems occurnon server end. 

  • Profile Image
    JotForm Support

    Answered by beril on August 23, 2016 at 03:37 PM

    Hi again,

    I am still trying to solve your issue on my side. However, I am getting closer. It might be related to your calculation fields which are h*v or ŠT. ART NA POLI.

    First of all, I've showed your calculation fields for testting on your cloned form. At that situation, I realized that the console errors are related to calculation of 1504 as you see below:

    I've deleted those fields for testing. At that situation, your form is loading fine on my side. It doesn't kill the browser.

     

    We would appreciate it if you could provide us any information about those calculations and conditions associated wıth that fields. There is an issue which causes loadıng slowly. However, I couldn't find it yet.=(

  • Profile Image

    Answered by info@pdfn.co on August 23, 2016 at 03:44 PM

    that part is calculation of how manz pieces fit onto one page.

     

    so we have page size (visina pole, dolzina pole)

    item size

     

    and this caluclates both options and uses bigger value for calculation

     

    wihtout these fields thw whole form is uselss.

     

    The strange thing is, that this part was initial item I made about a year ago and never had problems...

    Same formulas are used also in form https://form.jotformeu.com/60494452184357 which opens fine :)

     

    weirdest thing....

  • Profile Image
    JotForm Support

    Answered by Kiran on August 23, 2016 at 07:07 PM

    I have checked your JotForm and see that there are several conditional calculations on the form which seems to be causing the issue. As I check the browser inspector, I notice that there are bunch of error being reported with the calculations. Please see the screenshot below:

    From the form revision history, I see that there were some changes made to the form yesterday. Please try reverting the form to yesterday's version and see if that works. Please refer to the guide below that can help you in reverting the form:

    https://www.jotform.com/help/294-How-to-view-form-revision-history

     

    If the issue still persists, please let us know. We will be happy to assist you further.

  • Profile Image

    Answered by   on August 24, 2016 at 01:01 AM

    Again: no changes have been made to form or code - yes, yesterday when first noted problems the designer has been opened, but there were no changes.

    I tested this also opening a loned backup version of form, which hasn't been touched before for months and it produces same error.

    On the other hand, the form that uses only part of code (with no hidden text) is working fine (see above).

    The problem is core engine / server side 100%. It may be related to hidden text using em function.

    Please advise - you do probably have info about what has changed at your side recently, which could produce this fault?

  • Profile Image
    JotForm Support

    Answered by beril on August 24, 2016 at 03:28 AM

    Hello again,

    First of all, we are sorry for the confusion. You're completely right.=) According to my investigation, TypeError: e.split is not a function error is related to changes that we made in conditions.

    I have forwarded this to our developers to have it checked and fixed. Apologies for the inconvenience and thank you for your patience on this matter. We will update you on this thread as soon as this has been fixed.

  • Profile Image

    Answered by info@pdfn.co on August 24, 2016 at 03:56 AM

    Hello and thank you. I believe this will resolve some other users issues as well (At least from tickets i saw on forum).

     

    Please let me know when available...

     

     

  • Profile Image
    JotForm Support

    Answered by beril on August 24, 2016 at 06:45 AM

    You're most welcome.=) If you saw a similar thread on the forum could you please send the URL of the thread. We can also forward it to developers. Apologies for the confusion again. We will inform you as soon as possible.

  • Profile Image

    Answered by info@pdfn.co on August 24, 2016 at 08:15 AM

    This one for example has pretty much similar symptoms :)

    https://www.jotform.com/answers/911049-Form-not-loading-correctly-main-order-form-makes-the-browser-to-crash-in-embedded-version-and-direct-link-#14

  • Profile Image
    JotForm Support

    Answered by beril on August 24, 2016 at 09:38 AM

    Thank you for your time and effort, you're awesome. =) On that thread, the issue is related to Uncaught SecurityError: which is Blocked a frame with an origin for security on their website.

    However,we really appreciate you taking the time to share it.

  • Profile Image

    Answered by info@pdfn.co on August 25, 2016 at 03:24 AM

    Is there any progress regarding resolving our issue? I would need to further develop form... Thanks

     

    Any workaround for temporary access maybe?

  • Profile Image
    JotForm Support

    Answered by beril on August 25, 2016 at 04:50 AM

    First of all, thank you for checking the status of your ticket. Unfortunately, there is no update yet. However, one of our developers was already assigned to fix the issue and he is checking now. We will notify you here once we have an update on the status. Thank you for your patience.

  • Profile Image
    JotForm Support

    Answered by beril on August 26, 2016 at 02:28 AM

    Hi again,

    The issue should be fixed now.=) I've also checked your form. It is working properly on my side.

     

    Could you also check it on your side and let us know the result? If you need any further information, please let us know. We will be happy to assist you.

  • Profile Image

    Answered by info@pdfn.co on August 27, 2016 at 05:43 AM

    Thanks a lot for your help.

    Form works ok now.

    Best regards