What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    All States and Cities: Submit button gets stuck on "Please wait..." when widget is hidden with conditions.

    Asked by jfernandez926 on August 30, 2016 at 01:07 PM

    Hi guys, 

    I am having trouble submitting the forms on our website. It only works with the "condition" of choosing "Become a franchisee." That form goes directly to me....the other conditions are not working. The form just says "please wait" when somone hits submit. 

     

    Please advise. This is for my Contact Us Form

     

    Jennifer Fernandez

    Page URL:
    https://www.mytown2go.com/contact-us

    button not working contact us form please wait a US
  • Profile Image
    JotForm Support

    Answered by Kevin_G on August 30, 2016 at 03:38 PM

    I was able to replicate the issue on your embedded form and using the direct link to it as well, seems like there was an issue with the widgets that you're using on your form. 

    I have updated them and tested the form it should be submitting now, here is a screen-cast of my test: 

    Could you please try again? 

    If the issue still persists on your end, please try removing and adding the widgets once again to your form if possible, also re-embed the form, a fresh copy of the form should help. 

    Do let us know how it goes. 

  • Profile Image

    Answered by jfernandez926 on August 30, 2016 at 03:44 PM

    HI Kevin, I just emailed you but not sure if you get those. The only one that WAS working was the become a franchisee condition. If you do the following you will see that it does not work

    Become a driver

    state: washington

    city: puget sound

    This is when it does not work....It will not work with any other city either

  • Profile Image

    Answered by jfernandez926 on August 30, 2016 at 03:45 PM
    become a franchisee was always working....Its the only one that is working
    though....If you click on any other subject it does not submit the form.
    Please use, become a driver then click on washington, then puget
    sound....let me know if that works.....None of the cities are working
    *Jennifer Fernandez*
    *Director of Operations*
    *MyTown2Go*
    *917.579.0177*
    *www.MyTown2Go.com *
    ...
  • Profile Image
    JotForm Support

    Answered by Kevin_G on August 30, 2016 at 05:59 PM

    Apologies, I tested the form and noticed there was an error about required fields empty, but I tested your form now and I can see the issue, seems like there is an issue when the "All states and cities" widget is hidden with conditions, I checked the web console and when it is hidden with conditions it does not return any data so the form gets stuck on please wait and it is never submitted. 

    I will submit the thread to our second level in order to get this checked and resolved, we will let you know as soon as we receive news regarding this thread. 

     

  • Profile Image

    Answered by jfernandez926 on August 30, 2016 at 06:55 PM

    thanks so much for doing this....This is really the only way that it will work for our company. It is already live on the site so I want to fix this issue as soon as possible...thanks so much for working on this for us. 

     

    jennifer

  • Profile Image

    Answered by jfernandez926 on August 31, 2016 at 01:21 PM

    Hi guys, I have fixed this issue. No need for assistance anymore. 

     

    thanks!

     

    Jennifer

  • Profile Image
    JotForm Support

    Answered by Kiran on August 31, 2016 at 03:03 PM

    Thanks for letting us know. It looks like that you have removed the widget from the form and added individual fields with conditions. The issue is already forwarded to our backend team and you'll be posted here if there is any update in this regard.

    Thank you!

  • Profile Image
    JotForm Support

    Answered by TitusN on September 07, 2016 at 02:42 AM

    All states and Cities should be working properly now. 

    Sorry about that - please check and let us know.