Get rid of "please wait" message after pressing submit button.

  • Profile Image
    murcjot
    Asked on April 20, 2012 at 10:59 PM

    When I hit submit on my form I get a message on the button that says "Please Wait" before redirecting to the Thank You Page.

    How can I get rid of this?

  • Profile Image
    abajan
    Answered on April 20, 2012 at 11:42 PM

    Please do the following:

    1. Load the form into the form builder and while on the Setup & Embed tab, click Preferences

    2. When the Preferences window loads, click the Advanced Settings tab and then Edit Form Warnings

    3. Click "Please Wait..." (second to last warning), change the text to match whatever is on the submit button

    4. Click OK > Save > Close Settings > Save the form

    Now, when the submit button is clicked, it will simply become grayed out until the thank you page loads.

  • Profile Image
    murcjot
    Answered on April 20, 2012 at 11:53 PM

    I changed the size of the button so the "Please Wait" message doesn't align with the Submit, which means even if I change the wording, I don't think it will align with it. Is there a way to completely disable it?

    What about when you use a button image? Does this message not show up because it obviously wouldn't align with the text in a custom graphic.

  • Profile Image
    murcjot
    Answered on April 20, 2012 at 11:54 PM

    Just wanted to mention that your Customer Support is the reason I left a previous site and came straight here. I will be upgrading my account tomorrow because of how quickly you respond with helpful information.

  • Profile Image
    jonathan
    Answered on April 21, 2012 at 03:18 AM

    Hi murcjot,

    You can also try using space ( ) as replacement for the 'Please wait...' message. But it will still show the empty button in small scale.

    If you use image, it totally disappear after you click on the button (I think this is much more to what you prefer).

    Please inform us if you need further assistance. Thanks.