What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Error #502 - Bad Gateway

    Asked by ddejaynes on October 12, 2016 at 01:57 PM

    When we go to submit a form, the submit button changes to 'Please Wait' while the page loads. After a while, the form times out and an Error Message pops up with #502 - Bad Gateway.

    Can you please look into this?

    Thank you!

    Page URL:
    https://submit.jotform.us/submit/40196370801147/

    502 message please wait and loads
  • Profile Image
    JotForm Support

    Answered by Kiran on October 12, 2016 at 05:45 PM

    This thread seems to be a duplicate thread to https://www.jotform.com/answers/958589/ and so we are marking this thread as answered. If you have any questions in this regard, we request you to follow-up on the other thread.

    Thank you!

  • Profile Image

    Answered by ddejaynes on October 13, 2016 at 01:07 PM

    The issue has been fixed. We are now able to submit forms.

    Thank you so much!

  • Profile Image

    Answered by ddejaynes on November 28, 2016 at 01:06 PM

    Hello,

    This issue is happening again. The form affected is Shannon under ebartosh account.

    Today, there were 3 submissions submitted but no ID assigned and none of the emails are being sent.

    Can you please look into this?

    Thank you!

    Danielle

  • Profile Image
    JotForm Support

    Answered by Kiran on November 28, 2016 at 02:04 PM

    I was able to replicate the issue at my end. I see that there is an error 502 Bad gateway when the form is submitted. However, the submission is being displayed in the form submissions. But when I tried to submit the attaching a file, it is displaying the Thank you message correctly.

    I have tried changing the upload field not to allow multiple files and tried submitting the form which worked fine. I have reverted the file upload to accept multiple files. The form seems to be working fine now since as I tried to submit it, the Thank you message is displayed without any issue. 

    Please check and let us know if the issue still persists at your end. We will be happy to assist.