Square: This business can only process payments in USD but amount was provided in CAD error

  • Profile Image
    atytus
    Asked on October 13, 2016 at 05:38 PM
    Payment Error
    This business can only process payments in USD but amount was provided in CAD.
     
     
    I have square setup in the payment wizard as CAD and square signup is in CAD.
  • Profile Image
    Jim_R
    Answered on October 13, 2016 at 10:39 PM

    Hello, since you never mentioned the form you're working on, I checked all 3 of them and found out the following:

    1. Uninsured Services 2016 - 2017 Registration: This form uses Braintree

    2. test of Uninsured Services 2016 - 2017 Registration: This one uses Square

    3. US Registration: Doesn't have a payment gateway

    I checked form #2 above and this is what I saw when I checked your Square Integration:

    Please change it to CAD. Double check your settings within your Square Account too (not in JotForm) and ensure you've set the currency to CAD. 

    After doing both, give it another try and let us know how it goes.

  • Profile Image
    atytus
    Answered on October 14, 2016 at 10:01 AM

    Thanks for your quick response.

    I see you noticed I tried making multiple version of the same form, deleting and re-adding multiple processors, which for some reason broke other aspects of my form that I have been unable to repair (please see my other question)

    I can understand your confusion with my original question, as I didn't think you would look at my form so I didn't think to reset it to how it was as I was debugging other aspects. Prior to deleting and readding square, I had the currency set to CAD and was in Test mode. As per your request, I put it back to CAD and put it into test mode again, tried again, and I get the same error. Please see "Uninsured Services 2016 - 2017 Registration" form

    It seems like it's an issue with test mode. I put into live mode, and tried a transaction, and it worked. I really hope you can fix this because square doesn't allow $0.01 products so I'm charging myself $1 every time I want to test the form. :(

     

     

     

  • Profile Image
    Boris
    Answered on October 14, 2016 at 11:28 AM

    Thank you for the additional details, and our apologies for the inconvenience. We already have a report about this forwarded to our developers, here:

    https://www.jotform.com/answers/941492

    The problem, in short, is that your sandbox API that is used for testing has a "merchant location" in US, so it requires USD as its currency, and will not accept anything else. The location of merchant in the sandbox mode does not need to match your actual merchant location, as per documentation from Square:

    https://docs.connect.squareup.com/articles/using-sandbox/

    Working with sandbox locations

    Your sandbox account comes with a collection of mock locations. These locations are totally distinct from your actual Square account's locations.

    We have escalated your support thread to our developers as well, so they see this affects other users as well. If there is anything our developers can do about this from our end, will let you know through this support thread.

    Until then, you can set your form to use USD currency while in Sandbox Mode, and then change it back to CAD while in Live Mode. I hope this helps.

  • Profile Image
    NeilVicente
    Answered on October 17, 2016 at 03:31 AM

    Hi,

    The issue occurs only in sandbox mode. Live transactions shouldn't have been affected.

    In any case, we have just fixed the problem with sandbox mode.

    Cheers!