A Problem with The Site?

  • Profile Image
    spiderwebs
    Asked on May 07, 2012 at 01:13 PM

    Hello

    I have just upgraded to a Premiun account with jotform. Today I tried to create a new form. Having chosen 'Blank' it saved it to 'My forms', however it would not let me edit the title of the form or add any fields?

    Is there a problem with ther Joform site? please advise asap.

    Thank you.

  • Profile Image
    AtacanC
    Answered on May 07, 2012 at 01:23 PM

    I've just tried to create a new form and i wasn't able to reproduce the said issue. Which browser are you using? Did you also test it on different browsers? Can you please clear your browser's cache too?

    We'll be waiting for your response.

  • Profile Image
    spiderwebs
    Answered on May 07, 2012 at 02:07 PM

    Browser = IE9

    Cleared cache - still does not work. Over the last 6 months I have produced many form on my Free account. Only from yesterday when I upgraded top Premium has this problem started. it will let me edit existing forms ok but not any new forms

  • Profile Image
    Goldo
    Answered on May 07, 2012 at 02:34 PM

    Can you try it once more please as I have cleared your form caches. Would it also be possible for you to try using a different browser and let's see if your able to able to do things normally.

  • Profile Image
    spiderwebs
    Answered on May 07, 2012 at 02:51 PM

    Hi

    I have now installed Firefox and it seems to be working ok. Many thanks.

    Just one final thing. I have made a new  form but I can not remember how to select the email address that the form should be sent to once 'submit' is clicked?

     

     

  • Profile Image
    Goldo
    Answered on May 07, 2012 at 03:07 PM

    Go to Setup & Embed > Email Alerts > Add New Email > Notification Email.

    Then change the recepient E-mail.