What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Changes in forms are not saving

    Asked by FECHSTUDIO on November 13, 2016 at 10:01 PM

    Please help!!!


    I've been trying for weeks (or maybe months) to edit a Form and save it.
    It is simply impossible!!!


    When I click on the floppy disk image, nothing happens!!!


    Please help me with this!!


    My client is very angry because I can't make that changes.
    First I clone one of my existing forms in order to change the language, I'm able to do that, so then I rename the New form, so far so good.


    But when I make changes like rewrite everything in another language, when I try to save the form (as I said) and when I click on the floppy disk icon in order to save the form and being able to publish it, nothing happens!!!

    Neither happens with other icons when clicking like: E-mail, Publish or conditions icons.


    I've been doing this procedure several times with several forms with and I've succeeded.


    Please, tell me what to do, I thought it was going to be a matter of time, I mean, I thought if I come back to your site another day or something, it was going to be solved, but not.

    I already emptied the cache and stuff like that and nothing!

    Thank you very much in advance!!

     

    Screenshot
    in new form publish cache icon
  • Profile Image
    JotForm Support

    Answered by owen on November 14, 2016 at 01:45 AM

    Hi,

    We are sorry that you have had to deal with such an issue. It should be pretty frustrating even considering the time it has been lasting. 

    However, I have checked the revision history of your form. Some changes seem to have been made. And it looks like they took effect:

    I have also tested the form itself through your account and the buttons seem to be working without an issue. Can you please confirm this on your end as well? Have you also tried editing your form on different browsers? 

    We will be waiting for your feedback. Thank you for contacting us.