Autocompleted Address widget stopped working with TypeErrors in Browser Console

  • Profile Image
    robinbruce
    Asked on November 22, 2016 at 09:22 AM

    It just stopped working today. Below is a link to the form. 

    Can you help?

     

    https://form.jotformeu.com/62764242089360

     

    Thanks

  • Profile Image
    candy
    Answered on November 22, 2016 at 10:25 AM

    Hello,

    I have checked your form and I have seen that you did not enter Google Maps API Key into your Autocomplete Address widget as the following screenshot:

    You can get an API Key from Google Maps.

    Also, I have tested the widget and I have seen that if you want to change the address that you had already entered, you should refresh the page to autocomplete.

    Please try. If you need more clarification, do not hesitate to contact us.

    Thanks in advance.

     

  • Profile Image
    Rose
    Answered on November 23, 2016 at 06:13 AM

    Adding to my colleague words here  above, I would like to point that there is a ticket which has already opened for this issue. 

    Once it is fixed, you will be notified via this thread. 

  • Profile Image
    robinbruce
    Answered on November 24, 2016 at 06:16 AM

    thanks - i've added an api key and its still not working (plus I never had one before and its worked for a couple of months already).

     

    What can i try next?

     

     

  • Profile Image
    Boris
    Answered on November 24, 2016 at 06:50 AM

    Thank you for reporting this, it seems that there are some scripting errors when our widget tries to access the Google Maps APIs:

    I have escalated this to our developers as a bug report, and we will notify you through this thread when the issue is resolved. Thank you!

  • Profile Image
    TitusNdoka
    Answered on December 04, 2016 at 09:48 PM

    Hello,

    The widget has been fixed - it should work as expected with your API key.

    Give it a try and let us know.