What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Autoresponder Attach a File: PDFs are uploaded with 0KB size if their file name contains a space

    Asked by stevenkessler on November 27, 2016 at 02:32 PM

    One more wrinkle  --  2 of my pdf files show 0 KB for the attachment, which naturally doesn't open, since there's nothing there.  I've tried deleting those files from your system and re-uploading them, but the problem persists.  the problem ones are

    Chapter 1

    the Personality Traits

    the other 2 pdfs are attaching and opening fine.

     

    Can you see how to fix those two?

     

    thanks,

    Steven

    attached pdf autoresponder
  • Profile Image
    JotForm Support

    Answered by Mike on November 27, 2016 at 02:35 PM

    The Attach a File option accepts just one fine on my end.

    Could you please explain where do you see those 0 KB file? Please also provide the form ID/name in question.

  • Profile Image

    Answered by stevenkessler on November 27, 2016 at 03:09 PM

    forms are

  • Profile Image
    JotForm Support

    Answered by jonathan on November 27, 2016 at 04:48 PM

    I was able to reproduce the issue when I test submitted your form https://www.jotform.us/form/62914192695162 

    The PDF attachment in the Autoresponder email cannot be downloaded because its zero(0) KB in size only.

     

    But I cloned the form and test on my end and it was working properly. You can test submit my form https://www.jotform.com/63316409111951 (provide your actual email to get the auto email)

    --

    Can you try removing first the attached PDF on your form autoresponder and then re-attached. 

    See if this process fixes the problem. Let us know if issue remains.

    Thanks.

  • Profile Image

    Answered by stevenkessler on November 27, 2016 at 05:21 PM

    I did it all again for both forms:

    deleted the pdf

    saved the email

    saved the form

    Then signed out of Jotform, cleared the browser cache, closed the browser, reopened it, and loged in again.  Then re-added the pdf for each email, saved the email, and saved the form.

    Testing on a private window so there's no old cache problem, I re-submitted both forms and again got emails showing the pdfs with 0 bytes.  

    The pdfs are actually 196 KB and 94 KB.  Since I can't get to my documents library, I can't see how big they look on your system, but they're definitely 0 bytes when attached to the auto responder emails.

    Aack!

    These have been working fine for weeks, and my 2 other forms continue to work fine, so it's apparently something that affects just these 2 forms.

    Can you check the file sizes in your library or show me how to access that?

  • Profile Image
    JotForm Support

    Answered by jonathan on November 27, 2016 at 05:33 PM

    We apologize for the inconvenience caused. 

    We cannot check the size of the attached PDF on your form as there is no means to do it in the email editor.

    Can you share to us the PDF files you were trying to attached in the email. You can send it to our email as attachment at support@jotform.com

    In your email make this the subject of the message "Support forum ticket# 998427"  so we will be able to associate it immediately.

    Thanks.

  • Profile Image
    JotForm Support

    Answered by Boris on November 28, 2016 at 06:02 AM

    Thank you for sharing your files with us. I have tried replicating this issue on a cloned version of your form, and I've been receiving the following error when attempting to attach PDF files to the Autoresponder:

    Unsupported file type

    I have also tried attaching other PDF files, and same as with you, it is not working correctly on my end. The only files that are uploading correctly on my end are image files, while I'm unable to attach any PDF files with Firefox.

    In Chrome, I'm able to attach the PDF files, but if their name contains a space, the file I receive has 0KB. Only if its name was not containing any spaces, and when using Chrome with our v3 Form Builder, did the files upload correctly. What I mean is that I had to rename the files to this:

    Chapter_1_-_The_5_Personality_Patterns.pdf
    The_Personality_Traits_Associated_with_Each_of_the_Patterns.pdf

    I have escalated the issue to our developers as a bug report, but you should be able to upload your files successfully as well by renaming them as mentioned above, and then uploading them to your Autoresponders again by using the Google Chrome web browser.

    We will let you know through this support thread when there are any news about this issue. Thank you!

     

     

     

  • Profile Image

    Answered by stevenkessler on November 28, 2016 at 10:48 AM

    You are right.  Removing spaces from the file names solved the problem.  I had forgotten about trying that.

    Thanks for all your time and effort on this.

  • Profile Image
    JotForm Support

    Answered by Kevin_G on November 28, 2016 at 11:30 AM

    Glad to know that you were able to attach successfully your files to your form. 

    We will let you know as soon as we get updates regarding this ticket.