Bedingung im Formular funktioniert nicht

  • Profile Image
    leadtributor
    Asked on August 20, 2020 at 08:40 AM

    Hallo Zusammen,

    ich habe in den Bedingungen in meinem Formular eine Rechnung eingefügt. Jedoch wird der Wert nicht korrekt abgesendet. Es kommt jedes Mal etwas völlig anderes raus, als das, was richtig wäre.


    Können Sie mir sagen, was ich beim Eingeben der Formel beachten muss?


    Danke und Gruß 

    Katharina

  • Profile Image
    ReallyRozie
    Answered on August 20, 2020 at 08:55 AM

    Hallo Katharina,

    es tut mir leid, dass Sie Schwierigkeiten haben. Um mehr zu sagen, müsste ich das Formular sehen können. 

    Hier ist der Artikel über das Widget, den kennen Sie bestimmt https://www.jotform.com/help/259-How-to-Perform-Form-Calculation-Using-a-Widget
    Ansonsten hilft mir oft eine genaue Liste mit allem was zutreffen und nicht zutreffen muss, um die Bedingung zu erfüllen.
    Das ist oft mehr als man auf den ersten Blick vermutet.


  • Profile Image
    Tom_Goepel
    Answered on August 20, 2020 at 01:21 PM

    Hi Katharina,

    danke für deine Nachricht.

    An sich kann die Berechnung so funktionieren. Ich glaube allerdings, dass die Berechnung sich die falschen Werte aus den Feldern zieht. Auch wenn du Zahlenwerte eingestellt hast, werden 25% nicht als 0.25 ausgegeben, sondern als 25.

    Um mit den korrekten Werten zu rechnen, kannst du natürlich in der Formel /100 rechnen, oder aber viel einfacher mit Calculation Values (Rechenwerten) arbeiten. Diese können für Einmal- oder Mehrfachauswahl hinterlegt werden. Ich habe das einmal exemplarisch in einer Kopie deines Formulars gemacht:

    1597943931Kapture 2020-08-20 at 21.11.39

    Zu den Calculation Values findest du noch mehr Informationen in unserem Artikel:

    How-to-Assign-Calculation-Value

    Damit sollte es klappen. Falls nicht, schaue ich gerne noch einmal tiefer in deine Berechnung.

    Viele Grüße

    Tom

  • Profile Image
    Tom_Goepel
    Answered on August 27, 2020 at 11:26 AM

    Hallo Katharina,

    danke für deine Rückmeldung. Ich habe mir deine Berechnung noch einmal angeschaut.

    Bei den Berechnungswerten in den beiden Fragen hast du Kommas für die Trennung der Dezimalstellen verwendet. In diesem Fall musst du dem Rechner mitteilen, dass mit Kommas anstatt mit Punkten als Trennungszeichen gerechnet werden soll. Wie das geht, siehst du hier:

    1598541888Kapture 2020-08-27 at 19.22.44

    Wenn du möchtest, kannst du gerne meine Kopie deines Formulars für deine Zwecke nutzen. Ich habe die Berechnung mehrmals auf Richtigkeit geprüft. Du findest das Formular unter folgendem Link: https://www.jotform.com/202394615253958

    Ich hoffe die Berechnung klappt nun endlich :)

    Viele Grüße

    Tom

  • Profile Image
    leadtributor
    Answered on August 28, 2020 at 07:02 AM

    Hi Tom,

    dein Formular gibt das richtige Ergebnis raus. Korrekt. Meines aber nicht.


    Kann ich dein Formular irgendwie kopieren? Oder könntest du meines umbauen? Ich hab alles gemacht was du gesagt hast, und trotzdem sieht das Ergebnis so aus
    1598612528Bildschirmfoto 2020-08-28 um 1

  • Profile Image
    Tom_Goepel
    Answered on August 28, 2020 at 09:23 AM

    Hallo Katharina,

    tut mir Leid, dass es nicht geklappt hat. Ich kann die Berechnung gerne direkt in deinem Formular bearbeiten. Bitte gib mir einen Moment, damit ich die entsprechenden Änderungen vornehmen kann.

    Wie du ein Formular kopieren kannst, steht in unserer Anleitung: How-to-Clone-an-Existing-Form-from-Your-Account

    Ich melde mich wieder hier, sobald die Berechnung in deinem Formular funktioniert.

  • Profile Image
    leadtributor
    Answered on August 28, 2020 at 09:31 AM

    Danke Tom!

  • Profile Image
    Tom_Goepel
    Answered on August 28, 2020 at 09:42 AM

    Danke für deine Geduld.

    Ich habe den Fehler jetzt gefunden und in deinem Formular angepasst.

    Obwohl du den Rechner auf Komma statt Punkt für die Dezimaltrennstelle umgestellt hast, verlangt die Formel den Punkt für 0.15. Das sollte so eigentlich nicht sein.

    1598621903Screenshot 2020-08-28 at 5.35.

    Ich habe dafür ein Ticket an unsere Entwickler eröffnet, damit die Option angepasst werden kann und der Rechner auch Kommas akzeptiert.

    Deine ROI Berechnung sollte jetzt auf jeden Fall funktionieren. Ich habe gerade noch einmal getestet und das Ergebnis stimmte :)

    Bitte entschuldige, dass die Lösungsfindung ein bisschen gedauert hat.

    Für weitere Fragen sind wir jederzeit hier im Forum erreichbar.

    Viele Grüße

    Tom

  • Profile Image
    leadtributor
    Answered on August 28, 2020 at 10:47 AM

    tausend dank!