Invoice not being attached to autoresponder

  • Profile Image
    campsimgruenen
    Asked on April 09, 2021 at 03:31 AM

    Liebes Jotform Team,

    Leider sehen bei uns die Rechnungen noch immer etwas komisch aus (siehe link unten), obwohl ich alles versucht habe, sie anzupassen.

    https://eu-files.jotform.com/jotformpdfs/campsimgruenen/210772795949372/4931809438118893296/Invoice-NEU-Anmeldeformular-Camps-im-Gr-nen.pdf?md5=rbs8zCXh1M_SBtJiqvC7mw&expires=1617866681&nc=1

    1.Warum werden die Produkte (inkl. Preis) nicht korrekt angezeigt?

    2. Warum wird die Rechnung nicht automatisch an unsere automatisch generierte Email gehängt, obwohl ich das aktiviert habe?

    Würde ich über kurze Aufklärung freuen, danke und freundliche Grüße

    Paul

  • Profile Image
    Eduardo_H
    Answered on April 11, 2021 at 05:22 PM

    Hello, @campsimgruenen

    Please try removing the invoice from your form and generating a new one by following the steps below:

    1 - Disable the invoice from your Form using the form builder:

    1618175487_607365ff0b515_Screenshot.png

    2 - Remove the template of your invoice using your PDF Editor

    1618175595_6073666b32a64_Screenshot(1).p

    3 - Re-enable the Invoice on your form by toggling back the button of Step 1

    4 - Confirm if the new invoice model is included on your E-mail Settings. (Advanced Tab)

    Let us know if the issue persists.

  • Profile Image
    campsimgruenen
    Answered on April 12, 2021 at 02:54 AM

    Hi Eduardo,
    thanks for getting back to me.
    There seems to be issues with my PDF Editor. (see screenshot attached) 1618210464_6073eea0bdb6c_BildschirmfotoI have too many simple invoices there which I cannot delete. I would like to delete them all, create one simple invoice and then try again but it does not work. Could you please advise?

    Many thanks and best,
    Paul

  • Profile Image
    Eduardo_H
    Answered on April 12, 2021 at 04:36 PM

    Hello, Paul

    Could you specify what kind of error you're getting when trying to delete the PDF templates?

    On my end I could select among your multiple templates and find the Delete button:

    1618259522_6074ae426f536_Peek 2021-04-12

    Notice that you can skip the tabs by using the left/right ( ← /→ ) keys of your keyboard.

    Looking forward to your reply.




  • Profile Image
    campsimgruenen
    Answered on April 13, 2021 at 03:17 AM

    Thanks Eduardo for your response. I was able to delete all unnecessary tabs by using the arrow keys, thanks for the tip.

    However, it is still not possible to send out the invoice together with the confirmation email, Ive set up. Could you please advise??

    I have created the invoice, and activated invoice under the additional settings for the email notification (see screenshot 1), under payment methods (see screenshot 2 & 3).

    I am also not able to preview the invoice under payment settings (blue button). Not sure why this is the case.

    Appreciate your support, thanks and best,
    Paul

    1618298243_607545832d64c_3.png1618298243_607545830f817_1.png1618298242_60754582ebf2b_2.png

  • Profile Image
    Eduardo_H
    Answered on April 13, 2021 at 12:33 PM

    Hello, Paul

    I have created a clone of your form for testing purposes, and I couldn't reproduce the issue. The Invoice was sent attached to the autoresponder e-mail.

    Could you try changing the senders' address back to the default e-mail to see how it goes?

    --> noreply@jotform.com

    Here are the instructions on how to set the sender address:

    Guide: How-to-add-a-custom-sender-address-to-an-email-alert

    Also, could you indicate which are the e-mail addresses of the submitters, so we can check?

    As for the "Preview" button, it took me a while, but it did load on my end, so I don't believe this could be related to the issue.

    Looking forward to your reply.

  • Profile Image
    campsimgruenen
    Answered on April 13, 2021 at 03:22 PM

    Hi Eduardo,

    thanks for checking.
    I've tried to change the sender's address but nothing changed. When I send out the test email, the email was still without attachment.

    To your second question: The email addresses of the submitters are asked in the 6th Question of the form 'Email der Bezugsperson' - i have made a screenshot.

    Any idea what the issue is?

    Thanks again and best,
    Paul1618341724_6075ef5c7e2ad_Bildschirmfoto

  • Profile Image
    Eduardo_H
    Answered on April 13, 2021 at 06:00 PM

    Hi Paul

    Actually, the PDF attachment won't be sent in the test e-mail by default, so you'd need to try an actual submission.

    I also recommend cloning your form and turning the Mollie integration into Test Mode on the cloned version, so you can test submissions without making real payments.

    1618351204_60761464ba765_Screenshot(4).p

    This will also require special API keys. Please check this Mollie guide on how to get the test credentials:

    https://help.mollie.com/hc/en-us/articles/214041689-How-can-I-test-the-payment-methods-and-webhook-on-my-website-

    Let us know how it goes.

  • Profile Image
    campsimgruenen
    Answered on April 14, 2021 at 08:11 AM

    Hi Eduardo, thanks for this suggestion. Ive cloned the form and activated the mollie test mode.

    https://form.jotform.com/211033775979364

    I still don't receive the attachment in the automated confirmation email. You can also try if you want.

    Not sure what is wrong here.
    Thanks for your support in advance and best , Paul

  • Profile Image
    Eduardo_H
    Answered on April 15, 2021 at 11:54 AM

    Hello, Paul

    Please apologize for the late reply.

    I could reproduce the issue on my end. Now please try creating a new autoresponder:

    1618501919_6078611f13ef7_Screenshot(3).p

    Let us know how it goes.

    If the invoices still don't come through, we'll have to escalate this ticket to our DevOps team for a deeper investigation.

    Looking forward to your reply.

  • Profile Image
    campsimgruenen
    Answered on April 16, 2021 at 05:14 AM

    Hi Eduardo,

    Ive created a new autoresponder, also adjusted some of the settings but it still does not work. I wonder what the problem is. The autoresponder works perfectly but the attachment is still a problem. Would appreciate if you can further support or elevate this. I really need to find a solution for that.


    Thanks and best,

    Paul

  • Profile Image
    Vick_W
    Answered on April 16, 2021 at 06:10 AM

    Hi Paul,

    Could you please tell us if the form that you've provided us is a clone of another form?

    https://www.jotform.com/210772795949372

    I believe that the Invoice attached to the product list belongs to a different form. This is why it is not working.

    If you look at the PDF ID in the URL you'll notice that the PDF editor is showing a different ID whereas all the cloned forms have the same ID when the invoice preview is opened from the Product list.

    https://www.jotform.com/pdf-editor/10210673427707053?preview=true

    Could you please give us the form URL if this was duplicated? We will have to escalate this to our backend team.

    Looking forward to your reply.

    Thanks

  • Profile Image
    campsimgruenen
    Answered on April 16, 2021 at 01:55 PM
    Hi Vick,
    thanks for getting back.
    This is the original form where live payments are already activated
    https://form.jotform.com/210772795949372
    This is also the form where I would like to have the invoice attached to the email auto responder
    The is the cloned form where test payments are activated
    https://form.jotform.com/211033775979364
    Would really appreciate if you could support.I really don’t know what the problem is. When I did testings, I made sure that the invoice in the PDF Editor is connected to the clone form.
    There seems to be a technical bug.
    Thanks and best,
    Paul
    ...
  • Profile Image
    Eduardo_H
    Answered on April 16, 2021 at 04:38 PM

    Hello, Paul.

    I have now escalated the ticket to our DevOps team for a back end investigation.

    As soon as there is an update, you'll be notified via this support ticket.

    Meanwhile, don't hesitate to reply if you have any questions or any additional information.

  • Profile Image
    campsimgruenen
    Answered on April 16, 2021 at 05:11 PM
    Thanks - would be great to hear back from you shortly.
    Best,
    Paul
    ...
  • Profile Image
    campsimgruenen
    Answered on April 28, 2021 at 05:03 AM

    Hi Eduardo,

    just wanted to followup on my request above.
    Can you update me on the current situation? Would really like to attach invoices to the automated email notifications.

    Thanks and best,
    Paul

  • Profile Image
    Vick_W
    Answered on April 28, 2021 at 06:41 AM

    Hi Paul,

    We do not have an update available on this yet. We can not give you any ETA right now. However, I'm sending a request to the assigned to team check for an update. We will let you know here as soon as receive a reply.

    Thanks

  • Profile Image
    campsimgruenen
    Answered on April 28, 2021 at 06:54 AM

    Thanks for following up, Vick - much appreciated.

    Look forward to hearing from you soon,
    Best,
    paul

  • Profile Image
    campsimgruenen
    Answered on May 17, 2021 at 10:10 AM

    Hi Vick,

    any updates on my request above - would love to enable automatic invoice emails!

    Thanks and best,
    Paul

  • Profile Image
    Eduardo_H
    Answered on May 17, 2021 at 04:48 PM

    Hello campsimgruenen

    Unfortunately, there is still no fix from the back end team on this subject. I'll notify them asking for an update. We'll let you know when we hear from them.
    Thank you