Form in Preview/Public is inconsistent with editor

  • Profile Image
    WeLoveYou
    Asked on December 20, 2016 at 11:50 AM

    I have the problem that my preview/even my published form is not the current version I have in the editor (tried to clear the jotform cache, other browser, clear browser cache, create a template an on this base a new form...).

     

    Any help?

  • Profile Image
    Boris
    Answered on December 20, 2016 at 12:40 PM

    Our apologies for the inconvenience, if you have already cleared your form cache, but the form is still loading an older cached version of the form when you try to Preview it, it might be caused by a server lag between our EU specific datacenter where your submissions are stored and our US based datacenters.

    This can happen sometimes, and EU users might experience such issues with Preview not being able to load your latest edition of the form instantly.

    I have cleared your form caches from our servers, and I see that the correctly updated version started showing instantly:

    https://www.jotform.com/help/229-How-to-Clear-Your-Form-Cache

    Should you experience the same problem again, you can either try clearing your form caches from our servers by following the above linked guide, or if you wait for a little while the change to a form should be correctly seen as the update is only somewhat delayed.

    It is unfortunate that an account with such a lovely username like yours is also affected by the lag. :) If there is anything else we can do to help, please let us know.