Mutli-select with Translation

  • Profile Image
    aiven
    Asked on February 24, 2017 at 04:21 AM

    Hello.

    I have some issues using Translation with a multi-select

    As you can see when you refresh the page, the text appear and disappear quickly. Only the first line of text is displayed. The translation have no effect on the options in the multi-select.

    I use
    to display a second line. 

     

    Do you have an idea?

    Thank you very much.

  • Profile Image
    Mike_G
    Answered on February 24, 2017 at 07:14 AM

    I was able to reproduce the issue you're having and I believe the issue is caused by the HTML tags you added to the option(s) of the radio button field in your form.

    If you're trying to add a sub-label for each of the options in the field, maybe you can try using CSS codes to insert the sub-label instead. Since, from what I've noticed (but please let me know if I'm wrong), you don't require the sub-labels to also be translated to French.

    Thank you.

  • Profile Image
    aiven
    Answered on February 24, 2017 at 10:37 AM

    Hello.

    The bug also appear on the test question I added below. It has no HTML in it.

    Translation seems to just not work with Radio buttons.

    Thanks for your future reply.

  • Profile Image
    Mike_G
    Answered on February 24, 2017 at 12:25 PM

    Apologies for any inconvenience, however,  I can't seem to reproduce the issue you are having.

    On a clone version of your form, I have removed the HTMLs and set up the form's translation.

    https://form.jotform.com/70545169386970 (I'm not 100% sure if the translations are correct. I just used Google Translate for testing purposes to show that it is working on my end)

    And it seems to be working properly.

    My suggestion would be is to try to remove the translation on your form and try to set it up again.

    https://www.jotform.com/help/298-How-to-Make-your-Forms-Multilingual

    Thank you.