Submission not loading (i.e. Does not go beyond "Please wait..")

  • Profile Image
    rachelsingel
    Asked on April 18, 2017 at 01:38 PM

    Hello!

     

    I am sorry to bother you, though I am trying to submit an application for the 2017 M.A. Hadley Prize for Visual Art Application and after uploading all of the information and clicking "Submit" the button reads "Please wait..." though does not go beyond that. 

     

    Is there only any reason it may not load? 

     

    Thank you so much for your advisement!

     

    Best,

    Rachel

  • Profile Image
    John_Benson
    Answered on April 18, 2017 at 03:23 PM

    I checked the website URL (http://www.louisvillevisualart.org/contact-us/) you provided and it is working fine. I did a test submission and it was successful. I was unable to replicate the issue being stuck in the "Please wait.." button after clicking the Submit button.

    You can try re-embedding your form using the iFrame Method to avoid getting stuck in the "Please wait.." button. Here's a guide: https://www.jotform.com/help/148-Getting-the-form-iFrame-code

    If you're referring to a different website URL, please provide the URL so we can investigate it further. Thank you.

  • Profile Image
    rachelsingel
    Answered on April 18, 2017 at 03:53 PM

    Thank you. My apologies, here is the correct link:

    http://www.louisvillevisualart.org/hadley-application

     

    Again, any help would be appreciated! Thank you!

    Rachel

  • Profile Image
    John_Benson
    Answered on April 18, 2017 at 05:20 PM

    Hello Rachel,

    I was able to send a test submission to the website link you provided. Are you still having issue? I also can see that you embedded the form using the iFrame Method now. See image below of my test submission:

    Let us know if you still having any issue being stuck in the "Please wait" button. If you have other questions or need any help, please contact us again. 

    Thank you.