Take photo widget not working on Mac devices.

  • Profile Image
    veritas
    Asked on May 30, 2017 at 01:20 PM

    Hi,

     

    The take photo widget is not working on our form. Are there only certain devices that the widget can work on? Or only certain browsers? The wizard does not show up, rather, it stays a black box rather than provide an option for live photo. 

     

    Thanks

  • Profile Image
    John_Benson
    Answered on May 30, 2017 at 02:35 PM

    Hello,

    May we know what internet browser or system you used to test your form? I tried testing the Take Photo widget using my iPhone 6 and it is working fine on my end. Here's a screenshot:

    Please try removing the widget and add it again to your form. Also, an alternative way is to add a File Upload field to your form or the Image Upload Preview widget.

    Hope that helps. If you have questions, please contact us again.

    Thank you.

     

  • Profile Image
    veritas
    Answered on May 30, 2017 at 03:43 PM
    Hi, I am using a MacBook Air and Google Chrome
    Katie Lee
    Central Administrator
    614.216.5014
    Veritas Community Church
    ...
  • Profile Image
    Kevin_G
    Answered on May 30, 2017 at 06:34 PM

    Thank you for the details Katie. 

    I have not a MacBook, but as far as I can see the widget works on my  end using Google Chrome and Windows, could you please check that your browser is allowed to use your camera? 

    Here's a  link with info about it: https://support.google.com/chrome/answer/2693767?hl=en

    Could you please also test on this form: https://form.jotformpro.com/62796578486984 

    Do let us know if you can still replicate the issue, that will help us to know if there is something blocking the widget's resources, you could also test on incognito mode  or  connected to a different internet connection. 

    I will also ask for someone with a Mac device in order to know if we can replicate the issue.