Submit button says "Please wait..."

  • Profile Image
    Gregory J Ellis 
    Asked on July 31, 2017 at 01:16 PM

    This issue has been recurring for us...another customer complained today and we have received no submissions through our form for the past 2 months although a JotForm troubleshooter was able to submit.  http://www.onecoolearth.org/volunteer.html

  • Profile Image
    John_Benson
    Answered on July 31, 2017 at 03:28 PM

    I did a test submission and I was not able to replicate the issue. My submission was successful see the screenshot of the Thank You page below:

    If the issue persists, please try embedding the form using the iFrame Method. Here's a guide: https://www.jotform.com/help/148-Getting-the-form-iFrame-code

    Let us know how it goes. Thank you.

  • Profile Image
    onecoolearth
    Answered on July 31, 2017 at 03:37 PM

    Thanks for the quick response.  I see you used "Returning Volunteer" as your test case.  Can you use "New Volunteer"?  That seems to be the form criteria that triggers the failure.  

    Also, I updated our page to use the embedded iFrame option, but the problem persists.

    Thank you!

    Greg

  • Profile Image
    Mike
    Answered on July 31, 2017 at 05:27 PM

    I was able to reproduce the issue on your form, but it worked fine on a cloned version.

    There is a chance that something is wrong with integration settings. I would like to suggest removing the integrations one by one while testing the form to troubleshoot this further.

  • Profile Image
    onecoolearth
    Answered on August 01, 2017 at 01:37 AM

    After an hour of troubleshooting I narrowed it down to the Ticket Purchases widget.  For some reason, if any of these widgets were selected in the form, the form would not submit, even after I had deleted all integrations and email notifications/responses.  I simply replaced the Ticket Purchases widget with simple Multiple Choice checkboxes and the problem has been resolved!

    Thanks,
    Greg