Thank you message is not displayed if the form is embedded using its full source code.

  • Profile Image
    bisspuxi
    Asked on August 22, 2017 at 11:01 PM

    Hi

    I have created several forms. One example is below:

    http://www.nordangliaeducation.com/en/our-schools/shanghai/puxi/learning/extra-curricular-activities/eca-biscap-and-music-registration/secondary-eca-registration

    When I complete the form and click submit it goes back to the form rather thasn the 'Thank You' page and no data is submitted.

    The direct link works fine... I can complete and submit the form successfully:

    https://form.jotform.us/72269391302152

    And when I embed the snippet of code it works fine.

    Bus copying the entire source code doesn't work although the form displays correctly and allows the user to fill in the information - it just doesn't submit...

    Help greatly appreciated.

    Thanks

    Richard

     

  • Profile Image
    ashwin_d
    Answered on August 23, 2017 at 12:57 AM

    Hello Richard,

    I did check your webpage where you have embedded your form and I was able to find the cause of this issue. Your webpage has two form action tag and that us the reason why thank you message of form is not being displayed. Please check the screenshot below:

     

    Your webpage should have one form action tag. This is used when the submit button of webpage is clicked. Since you have used full source code to embed form and the first form action tag has URL of your own page, thank you message of your form is not displayed. 

    There are two options available to solve this problem:

    #1. Embed your form using any desired embed code instead of full source code.

    #2. Edit your webpage and remove the first occurrence of "<form" tag. You need to find and remove the following code form your webpage:

    <form method="post" action="/en/our-schools/shanghai/puxi/learning/extra-curricular-activities/eca-biscap-and-music-registration/secondary-eca-registration" id="form1">

     

    Hope this helps.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image
    bisspuxi
    Answered on August 23, 2017 at 02:43 AM
    ?Hi
    Kind thanks for the quick response and suggestions.
    I'm limited in what I can access on the page as it's in a restricted CMS. I'm copying the source code from the Jotform and pasting into a content box in the CMS. I've attached the complete source code straight from the jotform. What do I need to edit in this to make the page work?
    Thanks
    Richard Restell
    Publications & Communications Officer
    The British International School Shanghai, Puxi
    111 Jinguang Road, Huacao Town,
    Minhang, Shanghai, 201107
    Phone: +86 (0)21 5226 3211
    www.bisspuxi.com
    ________________________________
    ...
  • Profile Image
    bisspuxi
    Answered on August 23, 2017 at 02:43 AM
    ?Hi
    Just to let you know, I need to embed all the source code to ensure the page loads properly. If I just embed the snippet, the page does not load without a VPN... I am in China and many of our users in Shanghai, who have no VPN tell us the school Nord Anglia website content loads but the space where the form should be remains blank.
    I've tested this myself and without a VPN or proxy the form refuses to load and times out.
    However, when I embedded the entire source code it does load quite quickly but the issue with submitting content arose.
    You can see in the attached I'm pasting the source code into a content box ... the rest of the page is hard coded.
    Kind regards
    Richard Restell
    Publications & Communications Officer
    The British International School Shanghai, Puxi
    111 Jinguang Road, Huacao Town,
    Minhang, Shanghai, 201107
    Phone: +86 (0)21 5226 3211
    www.bisspuxi.com
    ________________________________
    ...
  • Profile Image
    bisspuxi
    Answered on August 23, 2017 at 02:43 AM
    ?Hi
    I also tried taking the compressed and refined version and placing in content section but the same issue arose. See attached the complete file.
    Thanks
    Richard Restell
    Publications & Communications Officer
    The British International School Shanghai, Puxi
    111 Jinguang Road, Huacao Town,
    Minhang, Shanghai, 201107
    Phone: +86 (0)21 5226 3211
    www.bisspuxi.com
    ________________________________
    ...
  • Profile Image
    Charlie
    Answered on August 23, 2017 at 03:21 AM

    Hi,

    Please note that we can't view images here in forum page if you are replying here via your email client and adding them as attachments. To share screenshots of the problem, please directly open this thread in a new tab using this link https://www.jotform.com/answers/1230208. Then in the reply textarea, use the upload image button to share your screenshots. 

    Have you tried embedding the form using the iFrame embed code generated in the "Publish" page in JotForm? You can learn more about it on this page: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code. After you have re-embedded it, please do share us the link to the website page so we can directly check what the error. 

    We'll wait for your response. 

  • Profile Image
    Welvin
    Answered on August 23, 2017 at 05:27 AM

    There seem to be a few issues in the page which is causing the form to malfunction. For example, the following errors in the page's console:

    Plus, the additional form action that my colleague has pointed out. 

    My suggestion would be to create a separate page, maybe an HTML page for the form source codes. Then upload this HTML file in your website root using FTP clients such as Filezilla and use its absolute URL as the link to your form. 

    Here's an example separate HTML page for your form: https://shots.jotform.com/welvin/html/1230208.html