Drop down menu working mode and live mode don't match

  • Profile Image
    vtiportal
    Asked on September 30, 2017 at 05:53 PM

    See attached. The selected by default has been disabled. It works fine in live mode. But in the working mode, the form displays "Select Your Phone" which should not be there.

    The form: https://www.jotform.com/build/72707836363261

    Can you fix?

  • Profile Image
    vtiportal
    Answered on September 30, 2017 at 05:54 PM

    This is the working mode.

  • Profile Image
    Mike
    Answered on September 30, 2017 at 09:06 PM

    Thank you for contacting us.

    It seems to be not happening with new fields. To fix this for old fields, try to select the field and then click on the Edit Options.

    Here is a quick animation:

    If you need any further assistance, please let us know.

  • Profile Image
    vtiportal
    Answered on September 30, 2017 at 09:55 PM

    It worked, thanks.

    But wouldn't it be better if it also works if the "selected by default" does not show anything under the advanced tab? If the "selected by default" shows nothing and it doesn't work, then that tool means nothing, so why even have it?

  • Profile Image
    Kevin_G
    Answered on September 30, 2017 at 11:15 PM

    It should work properly if the "selected by default" option is empty. Please if you keep experiencing the issue, try clearing your forms cache

    If that does not work and you experience the issue even after clearing your forms cache, please let us know.