Timer Widget: It's not included in the email template if the widget is hidden.

  • Profile Image
    Lurn_Inc
    Asked on October 09, 2017 at 04:46 PM

    I'm assuming that the note "This form component is not available for this form layout" refers to the global countdown widget we had put there before?


    If this is not available, The only last issue is that we need a way to get the timer duration results for everyone who completes the form.


    I see that we still have the other timer widget which is great. I just don't see where the final time duration is displayed for us to see upon completion of the form. This information was previously displayed in the Notification Email upon completion of the form.


    See screenshot : https://www.screencast.com/t/qbfijaGKducM


    Thank you!

  • Profile Image
    Kevin_G
    Answered on October 09, 2017 at 04:55 PM

    I have been testing this an I can se the issue happens when the Timer widget is hidden, I would recommend you to delete the first element on your form and keep just one timer widget. 

    Now, I can see that the widget is not included in the email template when it's hidden from the field settings. I will recommend you to instead show the widget on your form in order to get the time included in the submission. 

    I will also forward this thread to our second level so our developers can take a look on this, we will let you know as soon as we receive any updates about it. 

  • Profile Image
    Kevin_G
    Answered on October 09, 2017 at 08:22 PM

    I'm very hesitant to delete the other widget as the last time I deleted a widget I started experiencing the technical issues. :(

    I have cloned your form and deleted that element that does not seem to be compatible with the new form layout, the form worked on my end and please note that if you delete that element you can always revert your form to the previous version. 

    Reference: https://www.jotform.com/help/294-How-to-View-Form-Revision-History 

    Another oddity. Though the timer display is currently hidden ( and that's how it should be as I previously saved the settings as hidden) when I go to the settings now, the display timer is set to "yes", though it's still hidden and still doesn't show up in email template:

    This is because the widget is hidden from the field properties (it's a different properties section than the widget's wizard); however, this can be turned off by clicking on the widget, gear icon and going to the advanced tab, you should turn off the "Hide field" option: 

    I hope this helps. 

  • Profile Image
    Lurn_Inc
    Answered on October 10, 2017 at 08:39 AM

    Kevin,


    Your support has been superb!


    Thank you very much for providing all information and for fixing all issues in a timely manner.


    Happy to provide positive feedback on your behalf if there's a feedback form.


    Thank you!


    Marisha