New Form Layout: Products section not showing properly

  • Profile Image
    iklik
    Asked on November 01, 2017 at 11:18 AM

    Hi,

    I have cloned the form and it appears to be working ok now but it has caused an issue you solved previously on the old form.

    The additional products section cannot be seen as the box is too shallow (form needs to be longer)

     

    Can you please help us again with this?

     

    this is the cloned version of the same form.

    The issue started again once we cloned the form to fix the upload problems

  • Profile Image
    John_Benson
    Answered on November 01, 2017 at 11:37 AM

    I checked the direct form link (http://www.jotformeu.com/form/72991871817370) and it is showing properly. Here's a screen capture test:

    1509550219showza.gif

    After that, I checked your website (http://www.iklik.co.uk/order-form.html) and I was able to replicate the issue. Here's a screen capture:

    1509550578showza1.gif

    Please try re-embedding your form using the iFrame Method. Here's a guide that you can follow: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Let us know how it goes. Thank you.

  • Profile Image
    iklik
    Answered on November 02, 2017 at 07:33 AM

    i have done as you suggested using iframe but it is still the same problem

  • Profile Image
    aubreybourke
    Answered on November 02, 2017 at 09:27 AM

    I have escalated this issue to Level 2 support. They will investigate and post a response as soon as it is possible for them.

  • Profile Image
    Rose
    Answered on November 02, 2017 at 09:52 AM

    We are sorry for this inconvenience. 

    The ticket was assigned one of our developers but you may consider to increase the Iframe height for a solution. 

    When I increased the Iframe height, the products started to be visible as you can see here:

    1509630419Screen Shot 2017-11-02 at 16.5

    So, please try to re-embed your form with the following Iframe code and let us know if you still have problems about displaying the products. 

     <iframe id="JotFormIFrame-72991871817370" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://form.jotformeu.com/72991871817370" frameborder="0" style="width: 1px; min-width: 100%; height:1000px; border:none;" scrolling="no"> </iframe> 
     
    If the embed code does not work, please also try to increase the height value.
  • Profile Image
    iklik
    Answered on November 02, 2017 at 12:49 PM

    i have tried using the increased height and it still doesnt work

  • Profile Image
    John_Benson
    Answered on November 02, 2017 at 01:26 PM

    Hi, 

    The issue has been escalated to our developers. 

    I checked your website and I can see that the height of the iFrame code is still the same (640px) width.

    1509642982ohsms.gif

    Please try using the code provided by my colleague Rose.

    We will contact you again on this thread once we have any updates from our developer.

    Thank you.


  • Profile Image
    iklik
    Answered on November 03, 2017 at 12:58 PM

    i think we could get round this issue by using a lightbox instead of iframe.

    I have tried to do this but when the lightbox opens it has no form in it. 


    Any ideas?

  • Profile Image
    BDAVID
    Answered on November 03, 2017 at 01:55 PM

    As an alternate solution, you may clone your form: https://www.jotform.com/help/27-How-to-Clone-an-Existing-Form-from-Your-Account 

    Then switch your form Layout to the "All questions in one page" option:

    1509731392allquestionsinOnePage_001.png

    So, the form will display in the old layout, example: https://form.jotform.com/73065008880961 

  • Profile Image
    iklik
    Answered on November 06, 2017 at 04:25 AM

    I appreciate the alternative but the layout needs to be 1 question per page.


    i think we could get round this issue by using a lightbox instead of iframe.

    I have tried to do this but when the lightbox opens it has no form in it. 


    Any ideas?

  • Profile Image
    candy
    Answered on November 06, 2017 at 06:38 AM

    As the issue is related to a different topic, I have split the thread. Please follow your answer at the following URL: https://www.jotform.com/answers/1290938 

    Thanks in advance.