I get an error in the form after trying to submit it

  • Profile Image
    ibowden
    Asked on December 01, 2017 at 12:42 PM

    Hello!

    I have created a relatively-long form and not defined a single field in it as 'required.' However, when testing the form's functionality, I reach the end of the form and try to submit it and get an error message indicating "There are errors on the form. Please fix them before continuing."

    If it matters, the form is embedded on a WP website using the code <script type="text/javascript" src="https://form.jotform.com/jsform/73335296392261"></script>

    I'm actually testing the form through the live website: https://websmithian.com/client-intake-form/

  • Profile Image
    Welvin
    Answered on December 01, 2017 at 02:38 PM

    I have just tested your form twice and was able to submit it without getting the error. You seem to have figured it out already. If the issue persists, please give our iframe embed method a try: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code. This might help. Please update us here. 

  • Profile Image
    ibowden
    Answered on December 01, 2017 at 03:43 PM
    Yes, I got your two test when I got notifications in my inbox!
    I've used the iFrame code and had no errors! I actually hadn't figured
    it out totally - only that something do with WP was screwing things up.
    I think I'll use iFrame embedding from now on as it seems to work better
    than with the WP 3rd party publish tool.
    Thanks for the help!
    Ian
    ...