Why new fields not showing up on forms?

  • Profile Image
    SaraKrosch
    Asked on January 08, 2018 at 02:51 PM

    I've tried adding filed to an already published and saved form and they do not show up on the site.  I've cleared my history/refreshed and still no change.

    I added the widget Appointment Slot but it has not showed up.  I also tried to add a checkbok and it never showed up.

  • Profile Image
    jonathan
    Answered on January 08, 2018 at 04:06 PM

    I was not able to find the JotForm on the website URL http://www.hawaiicreativeretreats.com/ you provided. It will help us immediately check the problem if you can provide to us the actual form URL and the website URL where it was used.

    For now I could only assume that this could be the website instead http://www.makerfair.org/festivals/apply-spring-spree/  which I found the embedded form https://www.jotformpro.com/form/73617162414958

    Can you please tell us if using the live URL https://www.jotformpro.com/form/73617162414958 of the form reproduce the issue as well? Is there a missing field/s on the form?

    I also suggest you try first re-embed the form no the website using the form iframe publish code. Then check again if the published form on the website shows the up to date version of the form.

    Let us know if issue remains.

  • Profile Image
    SaraKrosch
    Answered on January 08, 2018 at 10:43 PM
    the site is https://www.hawaiicreativeretreats.com/
    sign-up/creative-retreats/
    the appointment field does not show up on my site in this form
    https://www.jotform.com/build/73445876214967

    I have re-embedded the form and still no change. I feel I may have to
    recreate the form because only this particular form is giving me problems.
    ...
  • Profile Image
    Nik_C
    Answered on January 09, 2018 at 03:20 AM

    I checked your form and website and I see that the field (the widget) is missing:

    1515485910Screen Shot 2018-01-09 at 9.18

    And it is showing in Edit mode:

    1515485949Screen Shot 2018-01-09 at 9.18


    I checked the field, but you have a condition that is broken:

    1515485976Screen Shot 2018-01-09 at 9.17

    And that's why the field is not showing.

    Please check and let us know how it worked.

    Thank you!