Some unrequired fields showing up as required.

  • Profile Image
    ZeshanHaider
    Asked on January 22, 2018 at 11:13 PM

    Hi,
    I have added some upload file fields with the label "Proporciona tu segundo pasaporte vigente en caso de tener uno (Boton adjuntar)" in my form and I haven't made them mandatory but when I view my form then these fields appear as 
    mandatory.
    Need quick solution.
    Thanks.

  • Profile Image
    Nik_C
    Answered on January 23, 2018 at 04:55 AM

    You have a condition that is making that field required:

    1516701174Screen Shot 2018-01-23 at 10.5

    So all fields included in the condition will be required unless the condition is true.

    Let us know if you have any further questions.

    Thank you!

  • Profile Image
    ZeshanHaider
    Answered on January 23, 2018 at 12:05 PM

    I got your point. So I excluded those button fields from that condition but by doing so i don't know why all the fields that were previously showing up on a particular condition are now always showing up. (even after disabling that condition)

    So now I am using the backup copy of the form. This is the new link of the form:
    https://form.jotform.me/80203164732447

    In this form, there is no "unrequire" condition applied on those button fields but still they are showing up as required.


  • Profile Image
    Nik_C
    Answered on January 23, 2018 at 12:34 PM

    I checked several of your fields and I could only see that some of them are set as Required in Options page: 

    1516728466Screen Shot 2018-01-23 at 6.25

    Do you have any field in particular that has this problem?

    We'll wait for your response.

    Thank you!

  • Profile Image
    Zeshan Haider
    Answered on January 24, 2018 at 12:08 AM

    Thanks. Issue solved.

    By the way, can you tell why in previous form after excluding the button fields from that condition all the fields that were previously showing up on a particular condition are now always showing up. (even after disabling that condition)?

  • Profile Image
    Nik_C
    Answered on January 24, 2018 at 02:28 AM

    I'm not quite sure what you're referring to.

    Could you please share the form ID where the issue persists and, if possible, please share the screenshot(s), here is how: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum

    We'll wait for your response.

    Thank you!