Hidden fields are still showing in preview mode

  • Profile Image
    kalexis
    Asked on January 23, 2018 at 10:36 AM

    Hello,

    I've hidden several fields in my form but when I preview the form I can still see the fields. Please advise.

    Thank you.

  • Profile Image
    Richie_P
    Answered on January 23, 2018 at 12:04 PM

    I have checked your form and I was able to replicate the issue.

    Kindly clear your form cache.

    If the issue still remains, you might need to delete the fields that can be viewed even if it is hidden and insert a new field to fix the issue. Or just delete those fields if they are not used.

    Let us know how it goes.




  • Profile Image
    kalexis
    Answered on January 23, 2018 at 12:48 PM

    Thank you for your assistance. I have cleared my cache and this did not resolve the problem. The fields have been used and deleting them means that I will lose information. Any other solutions?

  • Profile Image
    Richie_P
    Answered on January 23, 2018 at 01:46 PM

    I think I have found the problem, with further investigation I have found you have a broken show hide condition.

    You must fix the condition with the delete field so that no condition rules will be broken because of it, with my test I have added number 20 and 21 to the condition.

    Also, the condition must be met so that the fields will be hidden.

    Here is a sample screen cast.

    Hope you find this information useful.

    Please let us know if you need further assistance.