Form embedded on adobe muse is not working on Chrome,edge,opera and IE

  • Profile Image
    dyrck
    Asked on March 26, 2018 at 03:11 PM

    Hi Everyone, my JotForm isn't rendering in many browsers including Chrome, Edge and Opera but is fine in Safari and Firefox. It seems to work on Android and iOs devices too.


    It's possible that it works the first time the page renders but not on repeat visits but I'm not completely sure about this.


    The Adobe Muse code was used.

     

  • Profile Image
    Richie_P
    Answered on March 26, 2018 at 04:42 PM

    Kindly try embedding your form using the IFrame code to avoid conflicts with your website js scripts and your forms js scripts.

    You can check this guide on -Adding-a-Form-to-Adobe-Muse

    Please give it a try and let us know how it goes.


  • Profile Image
    dyrck
    Answered on March 27, 2018 at 10:52 AM

    Unfortunately using iFrame code hasn't helped.

  • Profile Image
    BJoanna
    Answered on March 27, 2018 at 12:18 PM

    Your form is working fine on my end in Google Chrome. 

    1522167072chrome.JPG

    However, I am using Windows and you are using Mac. I asked one of my colleagues to test your form on Mac and he was able to replicate the issue you reported. I was also able to replicate it when using Mac emulator. The form is not showing in Chrome, Edge and Opera.

    Can you please try to remove the script part of the iFrame code to see if that will resolve the issue. Use only this part of the iFrame code:

    <iframe id="JotFormIFrame-80744795284368" onload="window.parent.scrollTo(0,0)" allowtransparency="true" allowfullscreen="true" src="https://form.jotformeu.com/80744795284368" frameborder="0" style="width: 1px;

          min-width: 100%;

          height:539px;

          border:none;" scrolling="no">

        </iframe>

    If that does not resolve the issue, let us know and we will report this issue to our developers. 

  • Profile Image
    dyrck
    Answered on March 27, 2018 at 12:27 PM

    Interesting that you can see it. I have friends using PCs and they can't see it in Chrome and I am using an on-line testing site to render the page and it doesn't work there either. If you refresh the page does it still show? There has been a suggestion that it works once only.

    I will amend the code later and keep you updated. Thanks for the help, it's appreciated.

  • Profile Image
    Richie_P
    Answered on March 27, 2018 at 01:30 PM

    I am using windows with Google Chrome and I can see the form.

    Here is my screen cast:

    The issue seems to be on Mac as what my colleague have said.

    Please do try the solution given and get back to us.

    Thank you.

  • Profile Image
    dyrck
    Answered on March 29, 2018 at 10:56 AM

    All is working well now. Many thanks.